3

I have a Dell network printer mapped to my MAC. I'm able to print from applications without any issues, but when I try to print using terminal (lp or lpr), every file gets held up on the printer with "Hold for authentication"

I'm able to enter my details for the printer and the job goes through, but I'm prompted every time I try to print using lp. Saving my details to the keychain does not help.

1 Answer 1

1

I've seen this before. Try the following to resolve it:

  1. Send something to print so that you get the Hold for authentication error
  2. In Terminal enter lpstat -s
  3. From the output identify the printer name - it should be preceded by device for and followed by a colon : and a printer address. For example, if your output looked like:

device for Brother_MFC_9335CDW: dnssd://Brother%20MFC-9335CDW._ipp._tcp.local.

Then your printer name would be Brother_MFC_9335CDW

  1. Now enter the following command:

sudo lpadmin -p PrinterName -o auth-info-required=username,password

NOTE: Replace the PrinterName with your printer's name from Step 3

  1. You should be prompted for your Mac user password - enter this and press return

  2. Now try printing again as a test.

If it doesn't work, let me know and we'll troubleshoot further.


Since the above didn't work we'll repeat the process with some minor adjustments. More specifically, after Step 1 but before Step 2, do the following:

  • Open the Printer queue
  • Click on the 'Refresh' icon (it's the circular one with an arrow)
  • You should now get prompted for your credentials (i.e. username and password)

Now proceed with Step 2 from above.

5
  • Same issue, get the "Hold for authentication"
    – RedSharpie
    Commented Aug 20, 2019 at 9:43
  • Ok, just to be thorough, you had the Hold for authentication error while you carried out steps 2 etc? I've added more to my answer, but if it doesn't work let me know as there's still more we can try.
    – Monomeeth
    Commented Aug 20, 2019 at 10:03
  • Just following up on this. Did you get a resolution?
    – Monomeeth
    Commented Sep 8, 2019 at 5:10
  • Hi, yes the steps in the update worked. Many thanks.
    – RedSharpie
    Commented Sep 9, 2019 at 9:06
  • I have tried both variants (with adjustements and w/o) but neither of them worked for me (I still get "Hold for authentication" error). Can someone check if it is works also under macOS 11 (I am running 11.1)?
    – jendas
    Commented Feb 1, 2021 at 13:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .