3

I've had the Apple Battery Charger for a good long while now. After I bought it, I also bought a couple 8-packs of Sanyo Eneloop HR-3UTGA batteries, known to be the same model of battery included with Apple's charger. They worked great until a couple days ago. Now, with the Apple-branded batteries in the charger, it works fine. But when I put the Sanyos in the charger, nothing happens. No status light comes on. Nothing. Zilch.

I've tried swapping out different sets of batteries, and it seems that my charger has suddenly taken an intense dislike for the Sanyos, completely without warning. But when I put the Apple batteries in, no problem.

Can anyone suggest a course of action? Is it a bum charger now, or is something weird going on?

3
  • have you tried another charger? After time these rechargeable batteries lose their ability to hold a charge just like computers etc, Jan 14, 2012 at 0:13
  • If it still works with the Apple batteries, it isn't a bum charger Jan 14, 2012 at 0:57
  • I have neglected this one for too long. Turns out several of the batteries had been sitting discharged for up to a year; these won't charge now. Others that have been in use do charge normally. So is there a way to "reset" these discharged batteries?
    – Aaron Vegh
    Jan 25, 2012 at 18:37

1 Answer 1

2

Stating the obvious up front, the charger is only designed and tested to work with the Apple Batteries. It could be that the mAh of the Sanyo batteries is too different (out of range) for the Apple Battery Charger to properly recognize and charge to full capacity. The Apple batteries have a mAh of 1900.

If the Sanyo are 2400 or even 1600 the gap may just be too much so that the charger doesn't do its thing. As long as the charger is still able to charge the Apple batteries, the charger should not be bum.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .