0

I have an external hard disk drive that's a few years old and lately it's been causing some issues. It started by unexpectedly unmounting, and a few days later it wouldn't mount at all. If I open Disk Utility while the drive is connected, Disk Utility remains stuck showing "Loading disks" until I close it, and the application doesn't respond. I've already tried running "sudo ps ax | grep hfs" and stopping the disk, but that didn't do anything. I was able to mount the drive in recover mode. Each time I ran First Aid, it would get to the point of "checking catalog file" and stop making progress.

After this process I was able to mount the disk again briefly (not in recovery mode), but the same thing would happen before I could get the chance to access any files in the folders (it would unmount shortly after). The disk itself is spinning and not making any unusual sounds. Terminal shows that the SMART status of /dev/disk3 (external, physical) is "not supported", while for /dev/disk3 (external, virtual) SMART grep runs indefinitely & doesn't return a result. I'm using MacOS Mojave and the disk uses an Apple partition scheme.

I'm trying to figure out either a way to fix the problem, or if that's not possible, to be able to access the disk in a way that would let me look through it and transfer any data that's not backed up already. Any recommendations?

You must log in to answer this question.

Browse other questions tagged .