1

After laptop restart, my MacBook Pro 15" thinks my main laptop display is 47" screen. Resolution is showing 2880 x 1800 pixels and there is no other resolution available to be selected. I tried using the option + scaled selection, still only displaying single resolution.

Additionally my Mac is logging in way too long... like minutes and the usage is laggy as well as some graphical glitches are visible. Any idea how to troubleshoot or fix this issue? Also tried to reset PRAM and still nothing...

  • Have you tried reinstalling the OS? Have you got enough RAM and free disk space? – nekomatic Aug 20 at 14:07
  • No, but should be enough RAM and disk space (16GB ram and ~30GB disk space). It seems the issue was with some weird driver installation from the Roland A-800PRO music keyboard. After uninstalling driver and installing it again, the problem was gone. – Maksim Luzik Aug 20 at 17:43
2

I would try a third party executable that will allow you to list and change the screen resolution from the command line. cscreen works on macOS Sierra, High Sierra, and Mojave, there are also several projects on Github, but your mileage may vary.

  • 1
    If you don't want to mess with the command line, Display Menu from the Mac App Store is another option. – calum_b Aug 18 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .