2

I sometimes work on my MBP in the car (from the passenger's seat, of course) and it is impossible to see anything unless the screen is on the maximum brightness. Every few minutes, however, I have to repeatedly hit the F2 key to bump up the brightness because (apparently, at least) macOS thinks it knows better than I do what my brightness should be.

I normally have my Energy Saver settings set to NOT turn off UNTIL 15 minutes. But instead it turns WAY down in about 60 seconds, which (over time) becomes absolutely infuriating.

Even if I disable every possible power saving setting while on battery power, macOS still insists on doing as it pleases and ignoring my express commands. How can I prevent it from constantly dimming the screen, so I can actually see what's on my display?

So even with the following settings, the screen dims:

  • NEVER turn off display
  • DO NOT put hard disks to sleep when possible
  • DO NOT slightly dim the display on battery power
  • DO NOT enable power nap while on battery power

In case that is not enough detail, here is the output of pmset -g:

System-wide power settings:
Currently in use:
 lidwake              0
 autopoweroff         0
 standbydelayhigh     10800
 autopoweroffdelay    0
 proximitywake        0
 standby              1
 standbydelaylow      10800
 ttyskeepawake        0
 hibernatemode        3
 gpuswitch            2
 powernap             0
 hibernatefile        /private/var/vm/sleepimage
 highstandbythreshold 50
 displaysleep         0
 sleep                0
 tcpkeepalive         1
 halfdim              1
 acwake               0
 disksleep            10

Could some third-party utility be doing this? If so, which one? Or is this the work of macOS? If so, how do I prevent it from doing this?

1

Have you tried turning off auto-brightness on your Mac? That could be why it keeps adjusting the brightness by itself after a while (i.e., its ambient sensor thinks your display should be a different brightness and changes accordingly)

Here's a tutorial on how to turn auto-brightness off: https://www.techjunkie.com/disable-auto-brightness-mac/

I hope that helps!

  • Thanks, I made the change, and I'll test next time I'm in the car! – iconoclast Aug 19 at 4:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .