1

About 4 months ago I bought the Logitech G Pro Headset. I was satisfied with this headset but recently I've had some issues - it wouldn't always work on my Mac.

Maybe it has to do something with using it on my Playstation 4 as well. I used to be able to plug it in or remove and attach the mic and it would work again on my Mac. But now it just completely stops working. It uses the Mac's internal mic when I have the headphones plugged in.

I have tried:

  • plugging it in and out
  • restarting my Mac and plugging in and out the attachable mic

I'm certain it hasn't got anything to do with it not being compatible with the Mac as not have I found on multiple sites that it works on the Mac, it also worked for me just fine before.

I'm using an iMac (21.5-inch Late 2012) running on MacOS High Sierra (10.13.6).

Can anyone please help me find a fix for this?

  • 1
    Firstly, welcome to Ask Different! :) Just to clarify, have you tested the Logitech G Pro Headset mic on another device (just in case it has developed a fault)? Also, have you checked your settings in Apple > System Preferences > Sound > Input? – Monomeeth Aug 16 at 23:21

You must log in to answer this question.

Browse other questions tagged .