3

I'm on the latest public beta of macOS Catalina and it's supposed to use zsh as the default shell and it even shows that it is pointing to zsh in the users settings but whenever I open a new terminal window it says:

enter image description here

and even when I run that specified command, it says: no changes made

What do I do?

1
  • I upgraded to Catalina from Mojave. I expect that the default shell is still Bash because of the upgrade. It's not a fresh install. – CommandZ Oct 14 '19 at 16:21
7

Turns out the terminal app has its own settings for which shell to use. I had to go to terminal preferences and change the option for Shells open with to Default login shell:

enter image description here

0
2

Run your chsh command with sudo to make changes effective system-wide.

To change your default shell setting by using the shell,

You can first view the /etc/shells file to note the available shells and their paths on your system.

You can run chsh interactively (i.e. without any arguments) or with the -s or --shell flag, followed by the shell path.

0
-1

New user accounts will be created with zsh as the default shell. Existing accounts will keep whatever settings they already have in place.

1
  • True, but not sure how this answers the question. The OP tried to change shells apparently, but it didn't work as expected. – nohillside Oct 17 '19 at 10:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .