0

No matter how many combinations I try in Modifier Keys, unfortunately the control/command keys split responsibilities.

For example:

Control x, c, v all work fine, but Control z, t, r don't work - instead i have to use Command z, t, r.

Is there a way to have one of these buttons for all shortcuts? I tried changing Modifier Keys to use Command for all shortcuts but my Mac would not respect it. Also tried Karabiner. FYI I'm using a Razer keyboard.

TIA

edit: updated w/ image and scenarios -

current settings on my mac w/ razer keyboad

the above settings allows the following:

1) in TextEdit on my mac, the following commands work: ctrl x, c, v all works. but ctrl a, z do not work. in order to do ctrl a, z , i have to do windows key + a, z

2) in chrome, i have to do windows t, r in order to open new tab or reload. in chrome url area - i can only do windows + z, x, c, v, a (ctrl doesnt work with any of these despite working partially in TextEdit!!)

3) in gmail - windows a, z works. and ctrl x, c, v works. !

I tried multiple combinations in modifier keys section for keyboard but no matter what combination i try, the commands always split b/w ctrl and windows key. i also tried Karabiner using every variation under the sun but to no avail.

Is a computer reset my only option? Brand new mac been using for 1 month. :/

  • 1
    That doesn't sound normal. What is the application where this is happening? Can you take a screenshot of the top menu items related to this issue? Or you could just list what the menu items says about the shortcuts. Also is it just one application or are the shortcuts wonky like that everywhere? – Joonas Aug 15 at 14:46
  • hi thank you for your reply. i have updated my original post w/ image and additional information. thanks again – sw990 Aug 18 at 7:45
  • If you look at the menubar at the top, what does it say the shortcuts are for these commands? I'm trying to confirm the source of this. If the menu items list these shortcuts with some of them being ctrl and some of them being cmd, it might be an OS level change. If all of these commands say cmd+whatever, then it's likely something else. All of these commands by default use Cmd. You could also try booting to safe mode, which disables all third party apps so you could see if they affect it. And perhaps to make a new user, because that should reset all the settings that have been changed. – Joonas Aug 18 at 9:52
  • A bit repetitive, but; something has to be changing some of your shortcuts to use ctrl. My primary suspect is support.apple.com/guide/mac-help/… – If the top menu items say some of the shortcuts use ctrl, then it's likely this. Though I'm not sure how that could've accidentally happened. My next suspect is third party apps. If all top menu items say they should use Cmd, then it's likely a third party app... That's what I'm thinking right now. – Joonas Aug 18 at 10:06
  • Thanks for the reply - I think you are right. I looked at Chrome and clicked edit in the top menu, and sure enough the commands are split: ⌘Z ^X ^C ^V ⌘T ⌘N ⌘R ⌘A. I checked in a few other apps and the are also split. Looks like we might have found a solution! - Is there a way to change this system-wide? Ideally to have everything using the control button? – sw990 Aug 19 at 6:55
1

Please note that <Ctrl> on a "PC" keyboard is the same as <CTRL> on a Mac keyboard. Normally on a Mac you would need to use <Command>-C for copy, not <CTRL>-C.

Note that on a PC keynote <Alt> and <Command> keys are normally reversed. Maybe this is what you are trying to fix via the Modifier keys in the keyboard control panel?

Below is the mappings hatI have for his exact configuration: <CTRL>

  • Thanks for your reply. I updated my original question w/ scenarios - basically no matter what combination i try in modifier keys, it always splits between ctrl and windows key – sw990 Aug 18 at 7:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .