1

I deleted some games I played to free up hard drive space on my Mac and the Storage utility is still reporting the game taking up space even though I deleted it the other day (restarts don't help either).

I tried various guides to delete the index and it doesn't seem to affect the app index (only the files like Documents).

One guide I followed is: https://www.cnet.com/news/what-to-do-when-about-this-mac-lies-to-you/

This is what my storage app looks like: Entries stuck in Storage no matter what I can do.

  • Are you allowed to hit delete (right bottom) after you select one of them? Also, Quit the about this Mac app and then reopen it. You might be reopening the app after restart from its previous state. – ankiiiiiii Aug 14 at 11:48
  • The delete button was the first thing I tried. I also tried restarting the app and the computer. – SenorContento Aug 14 at 13:00
1

The list of available applications on the system is cached by LaunchServices. You can reset LaunchServices by running the following, which will take some time.

/System/Library/\
Frameworks/CoreServices.framework/\
Frameworks/LaunchServices.framework/Support/lsregister \
  -kill -r -domain local -domain system -domain user
  • So, after I restart my computer, I find the apps still listed there. I know they don't exist as I removed them from my Steam folder. Also, open in finder and delete don't work. I also tried rerunning the command as sudo and that doesn't work either. – SenorContento Aug 14 at 13:02
  • I had to go to steam and click uninstall for every game I had downloaded for Spotlight to register that the game was gone. Now I am curious to know what steam did to force it to stay registered. – SenorContento Aug 14 at 13:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .