4

I changed my "Default Account" in Mail Preferences:

And this changes my default "from" address when I send an email from (say) the Twitter app

But when I use the Mail app to send an email, it uses my old "from" address by default.

  • 1
    You can change the from email in the message regardless of which account is the default account. All you have to do is tap the 'Cc/Bcc, From:' field under the 'To' field. It will expand, then tap on the 'From' field and a scroll of all your accounts will be presented to you. This doesn't change the default obviously. – afragen Jan 15 '12 at 0:52

10 Answers 10

4

If you are creating a new message, then the "default" account will be used. If you are replying to a message in another account, that account will be used as the "from:" address.

It sounds to me like you want to reply to a message received on (say) Hotmail and have the message come "from" a new GMail address. This is not possible to do by default; you will need to change the "from" address manually.

1

It seems to be related to the order that the email accounts were created into iOS. If you look at the order of the Accounts in Settings > Mail, Contacts, Calendars you will see what I mean.

I don't know of any way to reorder these, except by deleting them and adding them back in the order you want.

1

I'm using iOS 5.0.1 and I'm not seeing your issue at all (iPhone 4 - UK - O2)

If I set the default to account A new mail inside does default to using the email address on A. if I change it to account B, newly composed emails goes from the email on account B.

replies to emails defaults to the email address on the account the email was received in. If account A is the default, and an email is received in account B, the from address will default to account B unless you change it whilst composing the reply.

1

For me, this happened because of faulty settings in the outgoing server panel applicable to the particular account. Failing the desired server, mail went to another server, with that server's email sending address. Resolved by deleting all the Mail accounts on the device, then transferring Mail account info from my computer back to the device via iTunes connection (see Info panel on iTunes).

1

This appears to be a "feature" in IOS7. It's been called Smart Mail Account Selection by this author: http://www.infoworld.com/d/mobile-technology/7-hidden-gems-in-ios-7-226957?page=0,0
who seems to think this is really great. And you are correct about the Default mail setting — it's now used for outside apps only.

Apparently Apple feels it knows better than you what email address you want to appear. I have not been able to get this to change no matter what order the accounts have been added. There doesn't seem to be a way to change the setting either. My son has 2 email addresses. He once sent me an email from one of them to an email address I rarely use. Now, every time I try to send an email to him at that email address, the Mail app changes my From address to that rarely used one. I'm hoping that if I manually change it enough it will "learn" that I prefer the other one, because I seem to have no other control over this. I have spent hours scouring the web for a way to modify this behavior, but have found nothing.

1

Go to Settings > mail, contacts, calendars > default account, tap on default account and change the default account. Job done.

  • This helped me. Here's what I had to do with IMAP under iOS 10.2.1: Settings > Mail > Accounts > (the account in question) > Account > Email. From there I could tap "Add Another Email..." or tap "Edit" to reorder addressed, or tap an address to make it the default. – Neil Steiner Mar 25 '17 at 17:02
0

The auto switching of the default account to the non-default account was happening to me and it was frustrating.

I think I may have figured out the problem: Google Sync. A day after I turned off my Google Sync setting (I think it said it may take 24 hours to update), the auto-switching sender problem was solved for me.

enter image description here

0

instead of going into All Inboxes; go into the Exchange or yahoo email box for example; the from: will be the one you want when you create new emails.

0

If I understand the question correctly you want to always send replies from the same server? I think what you want to do is configure your outgoing mail server on all your accounts to the the one you always want to use, ie copy the outgoing server from the account you want to use and replace the one in the other accounts with the one you want to use to send out your email.

It is easier to just leave things alone and select it on the from line each time but if you can not remember to the above "fix" should accomplish it, until Apple corrects it with a setting change.

Ed

0

This is the most annoying problem I've ever had with my iPhone. It's been months of searching but finally found where the old email was on my phone. I hope this works for you as well.

Settings -> Mail, Contacts, Calendars -> Tap on mail account -> (IMAP) Account -> Email -> Swipe to delete old one from the list.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .