2

I am copying a TM backup to a new drive over USB by drag&drop per Apple’s recommendation. But since it is more than two terabytes, I am concerned about the risk of interruption.

If I try to resume with rsync -avAX will Time Machine be able to continue using it? Another question/answer suggests I might have to ensure I have the latest rsync but will that be enough?

  • By drag & Drop? You mean in the Finder? That's usually not a good idea, so I'd be interested to see where Apple recommends this. When I've copied TM backups to larger disks, I've made a disk image with Disk Utility, or cloned with SuperDuper or CarbonCopyCloner. – benwiggy Aug 12 at 18:01
  • All of those are also subject to interruption. – WGroleau Aug 12 at 18:07
  • Also, can Disk Utility copy to a slightly smaller disk if both are bigger in capacity than the backup set? – WGroleau Aug 13 at 3:52
  • 2
    I'm pretty sure rsync doesn't support hard-linked directories (just hard-linked files), and Time Machine makes heavy use of hard-linked directories. – Gordon Davisson Aug 13 at 4:25
  • rsync won't create a Time Machine-capable volume, since it doesn't support copying hard-linked directories. Use drag and drop as recommended by Apple, I can certainly vouch for it: I successfully transferred my Time Machine backups from a 2 TB to a 4 TB drive. You could also create an image and restore that image on the new drive, then resize the volume (see apple.stackexchange.com/questions/204462/…). The drawback is that you need a third drive to store the image. – jaume Aug 13 at 6:25
1

Rsync, with the -E option, will copy the extended attributes and ACL of a file. The man page for rsync states:

-E, --extended-attributes copy extended attributes, resource forks

-E, --extended-attributes Apple-specific option to copy extended attributes, resource forks, and ACLs. Requires at least Mac OS X 10.4 or suitably patched rsync.

  • That's an older version, though, that allegedly had problems. Update, according to the item linked, changes it to -AX. I was just wondering whether it was reliable enough for Time Machine. Hopefully, I won't have to find out. Copy hasn't failed yet, but it says sixteen hours to go (after about three hours). – WGroleau Aug 12 at 20:45
-1

Well, in OS 10.14.6 the answer is NO, but not due to a flaw in rsync. Somebody bumped the USB cable when it was one-third done (estimating twelve hours to go).

I tried "rsync version 3.1.3 protocol version 31" installed/updated today by brew

When that failed, I installed another with Macports. It gives the identical version info but is in a different path. It too failed, same message.

Both of these claim to support ACLs with -A and extended attributes with -X

MBP-WWG:~ Admin$ sudo time  /opt/local/bin/rsync -aAX /Volumes/Nahshon/Backups.backupdb/ "/Volumes/Seagate Backup/Backups.backupdb"
Password:
rsync: opendir "/Volumes/Nahshon/Backups.backupdb/." failed: Operation not permitted (1)
rsync: get_xattr_data: lgetxattr("/Volumes/Seagate Backup/Backups.backupdb/.","com.apple.finder.copy.checkpoint#N",0) failed: Operation not permitted (1)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1209) [sender=3.1.3]

Looking at the first error, I tried ls on the source backup. Not permitted, even with sudo. And sudo chmod -RN fails to remove the ACLs. So, it must be SIP protected.

Update: as seen in comments, this error does not happen to everyone. I do not know why. I do know that before SIP, I occasionally had to relax permission restrictions on a backup set to get around a Time Machine bug. But Time Machine always tightened them back up on the next backup. Now, SIP won’t let me do that, but apparently at least one person does not have those restrictions.

  • Isn‘t this rather an edit to the question than an answer, considering that it ends with a question? – nohillside Aug 13 at 4:30
  • Ended with a question mark, not a question. Fixed. And the second attempt at copy hung during the prep. – WGroleau Aug 13 at 5:36
  • RE: "Somebody bumped the USB cable when it was one-third done", just bumping a cable shouldn't be an issue, I've carefully picked up and moved USB drives while copying without any issues as the cable were tightly fitted, but if the cable was pulled out then that's a different story not expressed. See my comment to your question. – user3439894 Aug 13 at 11:37
  • Yeah, shouldn't, but it definitely did. – WGroleau Aug 13 at 12:12
  • I just tried with rsync from Homebrew, and didn't get that error. So I'm not really sure whether the problem you see actually is related to the ability of rsync to copy xattrs and ACL. – nohillside Aug 13 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .