I'm running macOS 10.15 Catalina Beta.

When I try to install Spotify I see the following error:

enter image description here

Is this a Spotify issue or a Catalina issue?



6 Answers 6


Catalina requires all apps that are signed with developer IDs to be 'notarized' by Apple. In the absence of an updated version from the developer, you can try the following:

  1. Right-click and select "Open". This may bring up the same dialog, but with an option to Open the file anyway.

  2. You can get round this by removing the quarantine Extended Attribute on the file:

    xattr -d com.apple.quarantine /path/to/file

Naturally, this bypasses Apple's security precautions which exist to stop maliciously altered software from running.

  • 3
    This is fantastic! I had an issue with a component launched as a daemon by Adobe Creative Cloud, and so the 'right-click and select open' solution did not work. Changing the Extended Attribute worked miracles! Many thanks! (I keep forgetting that Extended Attributes exist — but even if I remember that, I hardly recall the attribute names...) Commented Aug 20, 2019 at 11:17
  • I'm not convinced this is always an application's issue. I'm having the same problem with 1 user on a DMG that is signed and notarized correctly - as far as i can see. Commented Jan 29, 2020 at 7:50
  • xattr: <path/to/file>: No such xattr: com.apple.quarantine. Please check again. Commented Apr 23, 2020 at 1:31
  • for older version of macOS

System Preferences -> Security & Privacy -> check Allow Anywhere

  • for macOS Sierra, High Sierra, Mojave

$ sudo spctl --master-disable

But if the Move To Trash issue still exists. This is because Apple has removed TNT certification. You may use codesign to resign it:

$ codesign --sign - --force --deep <app-path>
  • for macOS Catalina

I think codesign sometimes doesn't work for the notarization issue recently, so you should use xattr to remove the quarantine:

$ xattr -d com.apple.quarantine <app-path>

I have got a conclusion. When installing app from 3rd party on different macOS, you can try different ways when it comes up to Move to Trash issue. Meanwhile, I think this is a common issue for 3rd party apps, so you may change the title question to something that contains Cannot be opened or Move to trash as well.

  • The fix - System Preferences -> Security & Privacy -> check Allow Anywhere worked for me. Commented Apr 4, 2020 at 19:08

This is a notarization issue with Spotify on Catalina. Although you can right-click to open, you should be extremely cautious with that! That bypasses the mechanisms macOS is using to try to protect you from malware.

If you use this method to open something that you know, with 100% certainty, is actually from Spotify, that is a temporary workaround. But the failing here is that Spotify didn't get their software notarized despite knowing since at least June that it would be a requirement for Catalina. Please let Spotify know that you are dissatisfied with this level of carelessness, and do the same with any other vendor whose Mac software is not yet notarized.


I was facing the same issue while I was trying to install .Net Core 2.2 SDK.

dotnet-sdk-2.2.207-osx-x64 (1).pkg” can’t be opened because Apple cannot check it for malicious software.

And as mentioned in this forum entry all I had to do was to press the CTRL key while the installation was going on. I am not a Mac fan and that was the first time I was using the same, so I am not sure what happened when I was pressing CTRL key. Sharing this info for people who needs a quick resolution to this problem.


You can fix this problem by right-clicking on that .dmg or .pak file and choose open.

Here is the video to fix that type problem:



After unzipping the mac sqldeveloper.zip file, you will find the SQLDeveloper.app file.

Copy the SQLDeveloper.app to Applications folder. Later execute the below command in terminal.

xattr -d com.apple.quarantine /Applications/SQLDeveloper.app
  • Is there an echo in here?
    – benwiggy
    Commented Feb 12, 2020 at 17:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .