1

I've been having a problem with Security Update 2019-004 10.13.6. When it was time to restart to complete the update, the screen went black and the mouse cursor moved to the top left corner (I could still move it using the mouse). After a while it was obvious it was stuck, and the only way out was to power down using the power button.

I've also tried installing it in Safe Mode, no luck. I also tried Internet Recovery and the problem persisted.

Whether I try to restart or shutdown, same problem.

Surely there's an issue with whatever program or script whose job it is to install the update. I've done quite a bit of "googling" and cannot find where/what it is and how to remove it so that it won't try to execute. If I can't find that, the only way to ever be able to restart/shutdown properly ever again might be a clean install, which I'd rather not do (lots of stuff configured on this iMac...)

The machine is a mid-2011 iMac running High Sierra.

Any ideas?

Thanks!

  • Can you get to [regular] Recovery? Simple OS reinstall over the top of the existing one is the usual 'fix' for these busted security updates - I've had a few here on various machines… though, fingers crossed, none for a while… ;) – Tetsujin Aug 10 at 15:38
  • @Tetsujin Not sure what "regular" recovery is? This is what I did with Internet Recovery but it didn't work. – MetalMikester Aug 10 at 15:48
  • In that case, just use Time Machine & overwrite the whole lot. Nuke & pave; probably a lot simpler than trying to figure out in terminal which is the spare temporary partition that's being used to run the installer & failing. – Tetsujin Aug 10 at 15:51
  • @Tetsujin ugh... This started a couple of weeks ago. I don't know if I want to go that far back. – MetalMikester Aug 10 at 16:13
  • Clean install with a temp admin account, update then migrate your real account; ought to bypass the issue. – Tetsujin Aug 10 at 16:21
1

Re-installing as suggested above will fix the problem - temporarily! The next day you will end up in exactly the same situation, unless you stop all automatic updates from taking place.

The cause of the problem is a BUG in the 2019-004 10.13.6 High Sierra update, affecting my Mac Mini Server mid-2011, and obviously more mid-2011 machines.

I have forwarded the info to Apple, but don't hold your breath wile waiting for a correction. Mid-2011 machines are close to extinct and all updates for those will soon, if not already (?) stop from being developed.

  • Yes, that was my impression as well. I guess I just have to let it sleep for now. Unfortunately my iMac has a bad habit of waking up for no reason (I've gone through every troubleshooting method I could find on the subject), so sometimes I'll find it's been running for hours while I was away, just sucking up power for no reason. – MetalMikester Aug 15 at 13:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .