1

I am currently having problems visiting archive.org

example link

Safari 12 (and 13 b4) on Mojave shows the following error:

kCFErrorDomainCFNetwork error 303

enter image description here

Things I've tried:

  • disable all extensions
  • Develop > Empty Caches
  • trashing Safari.plist
  • booting into Safe Mode
  • recovery mode + Disk Utility First Aid
  • different DNS servers

All have had no effect.

Strangely, the problem does not appear in Safari Technology Preview, Chrome, Opera or Tor.

  • stackoverflow.com/questions/2897610/… DNS failure? – ankii Aug 10 at 13:40
  • Mine is error code 303, not error code 2 as in the other Q. But I tried different DNS servers (8.8.8.8, 1.1.1.1, AdGuard DNS, Alternate-DNS, my ISP DNS). But with DNS wouldn't all browsers be affected? This only affects Safari (my main browser) but not Safari TP, Opera, Chrome or Tor. – Matt Sephton Aug 10 at 13:48
  • 1
    From Apple Developers documentation, Error 303 refers to HTTP Server Parse Error. Which means, safari could not understand the response returned from the server. developer.apple.com/documentation/cfnetwork/cfnetworkerrors/… Unfortunately this does not solve your problem, but allow us to understand it better so we can try to find the real cause – Prado Aug 10 at 19:37
  • You already tried disabling extensions.. Did you try to open a Private Safari window? And access that site on the Private window? – Prado Aug 10 at 19:43
  • @Prado sadly i did not try that before finding the solution. Given that we now know the solution, do you think it would have worked? – Matt Sephton Aug 11 at 14:50
0

OK, this solution is the strangest thing. I found the solution on a Russian site, but now that the search terms for the solution are known you can find at some other sites.

The problem is a result of Safari holding too much local data for the site in question and failing to deal with that correctly. I use archive.org a lot so I had lots of LocalStorage and Cookie data for that site. The fact that this data is only in Safari, and none of my other browsers explains why they could browse the site just fine.

So, the solution:

  • Go into Safari > Preferences > Privacy
  • Search for "archive.org"
  • Click Remove
  • The problem goes away

Here's a video showing the problem before and after: https://imgur.com/gallery/d1P1FCi

fix kCFErrorDomainCFNetwork error 303 in Safari on macOS

I've reported this to Apple with full logs as radar #14814758.

  • I was about to suggest this, but stopped when I saw "deleted Safari.plist". – ankii Aug 12 at 10:56
  • @ankiiiiiii i'm sorry I do not understand your comment – Matt Sephton Aug 12 at 15:43
  • 1
    I was about to suggest clearing website data, but stopped when I saw in your question, "deleted Safari.plist". I don't know how I thought of both of them as the same. – ankii Aug 12 at 15:45
  • @ankiiiiiii yes, it's also surprising that deleting caches did not clear the local storage – Matt Sephton Aug 12 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .