15

I have my Google Calendar synced up to my iPhone 4S and by all the settings I can find, it looks like I am supposed to recieve alerts 15 minutes before every event. However, this has never happened.

How come there is no alert being displayed when an event is upcoming? I can see it in Notification Centre, but there is no banner or alert.

3 Answers 3

8

Something that seems to work for Google calendars: on your phone, go to Settings => Mail, Contacts, Calendars. Scroll down to the Calendars block. Select Default alert times. You can then chose phone alerts by type of event.

4
  • 1
    This works for me, iPhone 8.
    – Ardee Aram
    Jan 8, 2018 at 15:28
  • 1
    It looks like on iOS 12 this setting has moved to Settings -> Calendar -> Default Alert Times
    – jrh
    Jan 15, 2020 at 16:35
  • Also I'd like to add, I don't understand why a setting for an app I don't use (the builtin iOS calendar app) has the ability to override the settings for Google Calendar, but this seemed to work.
    – jrh
    Jan 15, 2020 at 16:58
  • I'm not sure now, the first notification worked but two of them later on never happened.
    – jrh
    Jan 16, 2020 at 0:47
4

Well, in case anyone is monitoring this, I found the answer on another site!! It has to do with using Mac (or iOS) Calendars, where you've subscribed or otherwise display a google calendar. On the Apple side, it will set up a default notification and there appears to be a bug or miscommunication between Apple and Google. So you have to turn off alerts on the Apple side. Doing so will allow Google Calendar alerts on the Google side (if you have any set up) to be sent normally, at the correct time, only once (or how ever many you've set up), and from the correct official google calendar account. Here are the instructions from http://support.amitree.com/en/articles/1551880-receiving-too-many-email-alert-notifications

How To Stop Them You can disable these additional Apple email alerts by going into your Apple Calendar settings on your iPhone, iPad, or Apple PC. The suggestions below should not stop the Push Notifications on your device.

iPhone/ iPad Instructions

  1. Open the Apple Calendar app
  2. Look for and Tap on (!) Calendars at the bottom of the screen
  3. Scroll to find the relevant Calendar (i.e. Folio Transactions, {name}'s Transactions)
  4. Tap on the (!) to the right of the Calendar name
  5. Scroll down to Notifications section
  6. Tap the toggle switch to disable Event Alerts

Apple/Mac PC Instructions

  1. Control-click (right-click) on the name of the calendar (i.e. Folio Transactions) in the calendar list, then choose Get Info.
  2. If you don’t see the calendar list on the left, choose View > Show Calendar List.
  3. Select “Ignore alerts,” then click OK.
1
  • I had to reinstall the calendar app just to do this. Thanks for posting! Mar 7, 2020 at 16:30
1

I have also been having the same problem and have found that the solution is to set the reminder in the Google Calendar web interface to "pop-up". You can set this to be your default reminder by going to Settings -> Calendars -> Notifications (in the same row as your calendar). You can set up multiple reminders here.

I'm fairly certain that this didn't used to be the case but I'm not sure when it changed (or if it definitely did change). For reference, I'm using an iPhone 3GS on iOS 5.1

1
  • It doesn't seem that the "pop-up" option still exists in Google Calendar, the only choices are "Alerts" or "Desktop Notifications".
    – jrh
    Jan 15, 2020 at 16:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .