0

When I updated my MacBook Air (5,2, mid-2012) the installation got hung up and it started chiming as if there was a memory issue... I have attempted to run AHT, and either option-D or D get "Cannot Load EFI/Drivers/Testsupport.efi" Apple Support either did not know what that meant, or that it was caused by my third party (OWC) SSD. Tried the GitHub site to no avail (both loading and/or booting from a USB). My apologies in advance if this is reinventing the wheel...

1

I've tried Opt-D, just D, and making a USB from the Github site… it also appears to be more widespread than just lil ol’ me… MacBook Pro 2013 - cannot load Apple Hardware Test

0

I would manually download the AHT for your MBA and run it from a USB. The steps to do this are as follows:

  1. Create a bootable USB flash drive by using Disk Utility's Erase function. Make sure you choose OS X Extended for the format and the GUID Partition Map for the scheme. For the purposes of these steps, also give your USB the name AHT when you're erasing it.
  2. Download the AHT for your particular MBA here
  3. Mount the downloaded image (it should mount as AHTCThree)
  4. Now you will need to copy the AHT to your USB flash drive. To start, Launch the Terminal app (usually found within the Utilities folder)
  5. In the Terminal window, enter the following:

    cp -r /Volumes/AHTCThree/System /Volumes/AHT/

  6. Now we need to make the USB flash drive bootable, so enter the following line in Terminal:

    sudo bless --folder /Volumes/AHT/ --file /Volumes/AHT/System/Library/CoreServices/.diagnostics/diags.efi --label AHT

  7. Enter your Admin password

  8. Leave the USB flash drive plugged in and restart your MBA

  9. Immediately hold down the Option key

  10. Select the AHT from the list and boot up

NOTE for other readers: - The AHT download and Terminal commands used in this answer are only for Mid-2012 MacBook Air models (both the 11" and 13"). Do not attempt this if your model Mac is different!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .