2

I'm trying to create a shortcut in Terminal and I need to provide the file path to the folder I want to jump into. To find out the file path, I dragged the folder into terminal and the output was:

/Users/myname/Library/Mobile\ Documents/com\~apple\~Pages/Documents/Filmmaking/Non-VR/Feature 

However I feel like the spaces aren't going to be allowed, and I'm not sure if I should be including the parts like "/com\~apple\".

For the record, this is a folder within iCloud so I'm not sure if that makes a difference with the file path.

How can I format this file path to get it right?

2

This should be the correct format.

Spaces are not 'allowed', but escaped by a preceding backslash that wouldn't be visible in Finder.

To verify, use the exact path and add a cd  (note the space character that's usually killed by SE-rendering) before it, press enter, and find yourself at the location in Terminal. Alternatively, precede it with open  and see a Finder window open at that location.

  • @KingTim Did you also add the space character? – LаngLаngС Aug 9 at 16:23
  • 1
    Thank you, it worked! For some reason even though the file path I provided for the alias was /Users/myname/Library/Mobile\ Documents/com\~apple\~Pages/Documents/Filmmaking/Non-VR/Feature, when I typed the shortcut word into terminal, it added an additional /Users/myname/ in front. So I removed that part and started the alias with /Library instead, and it worked. Thanks for your help! – KingTim Aug 9 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .