1

I had water damage on my MacBook Pro trackpad. After that my mouse cursor started randomly trembling. I turned off the MacBook, washed it with isopropyl alcohol and after that it began to randomly hang.

It can hang on boot, after login or after some time of working.

I thought I could check it by using a process of elimination by disabling kexts in normal mode, as in safe mode the MacBook seems to work fine (i.e. it doesn't hang about 12 hours).

So I decided to compare kexts, which only load in normal mode. Below is a list of those kexts:

 com.apple.driver.AppleFIVRDriver (4.1.0)  
 com.apple.driver.AppleSMCLMU (211)  
 com.apple.vecLib.kext (1.2.0)  
 com.apple.iokit.IOAudioFamily (206.5)  
 com.apple.iokit.IOHDAFamily (281.52)  
 com.apple.driver.AppleHDAController (281.52)  
 com.apple.iokit.IOSlowAdaptiveClockingFamily (1.0.0)  
 com.apple.driver.AppleIntelSlowAdaptiveClocking (4.0.0)  
 com.apple.driver.AppleOSXWatchdog (1)  
 com.apple.driver.AppleHV (1)  
 com.apple.driver.AppleSSE (1.0)  
 com.apple.plugin.IOgPTPPlugin (680.15)  
 com.apple.iokit.IOAVBFamily (683.1)  
 com.apple.iokit.IOSerialFamily (11)  
 com.apple.iokit.IOBluetoothSerialManager (6.0.7f15)  
 com.apple.iokit.IOUserEthernet (1.0.1)  
 com.apple.driver.pmtelemetry (1)  
 com.apple.AGDCPluginDisplayMetrics (3.20.16)  
 com.apple.GeForceTesla (10.0.4)  
 com.apple.driver.AppleUpstreamUserClient (3.6.5)  
 com.apple.driver.AppleMikeyDriver (281.52)  
 com.apple.kext.OSvKernDSPLib (526)  
 com.apple.driver.DspFuncLib (281.52)  
 com.apple.driver.AppleHDA (281.52)  
 com.apple.driver.AppleHDAHardwareConfigDriver (281.52)  
 com.apple.driver.AppleMikeyHIDDriver (131)  
 com.apple.driver.AppleTyMCEDriver (1.0.3d2)  
 com.apple.driver.AudioAUUC (1.70)  

I've also tried to start Apple Hardware Test (AHT), but AHT didn't launched properly. Either AHT stacked in choosing WiFi or after 10 minutes show error.

How can I proceed to identify which hardware part(s) are broken? It happens with MacBook Pro 2010 Mid 13"

  • Welcome to Ask Different! :) Can I ask you to please edit your question to include the exact model go MacBook Pro you have?Also, can you clarify what you meant by "I've also tried to start Apple Hardware Test, but it didn't work." That is, what did you do and what actually happened? Finally, when you say it seems to work fine in Safe Mode, for how long have you tested it in Safe Mode to determine this? – Monomeeth Aug 9 at 9:34
  • Just so we are clear here, you are looking for a software solution to a hardware problem? Or am I missing something here? – Steve Chambers Aug 9 at 20:40
  • No I'm looking for software solution to identify hardware problem – Paltus Aug 9 at 21:10

You must log in to answer this question.

Browse other questions tagged .