This is my first question so please pardon my mistakes. I use a Mid 2017 MacBook Pro with a HP V270 Monitor. The monitor connects fine using a USB-C to HDMI cable but the issue I'm having currently is that my monitor randomly goes off and then comes back on after few seconds. IT seems to be a connection issue but I'm not sure how to verify that but an odd that I noticed in the settings is that there isn't a picture on the monitor display settings but my MacBook screen displays a picture. Please do not confuse the picture I'm referring to with the on the hardware screen. Hardware screen shows a picture but goes off randomly. The screen in the picture above remains black no matter how I tweaked the settings beside it. Also I'm currently running the Catalina beta but I do not think the issue is from the beta because I've seen other users experience same issues.

MacBook Pro Mid 2017. 4 USB-C Ports and I've connected with both my lid open and closed(using an app called InsomniaX). I'm also using a direct cable from my USB-C port to HDMI.

  • The 'black screen' icon in the prefs pane is default. Mine shows the exact same icon for 2 perfectly-working external monitors. – Tetsujin Aug 9 '19 at 6:46
  • I've added an answer, but it'd be good if you could edit your question to clarify which model MBP you have (i.e. 13" v 15", and if 13" how many USB-C ports)? Also, are you connected to the external display in closed-clamshell mode (i.e. with your MBP lid closed), or are you trying to use both the internal and external display simultaneously? – Monomeeth Aug 9 '19 at 10:13

Assuming your cable is connected securely at both ends, the first thing to try is connecting the HP V270 display to a different USB-C port to see what difference, if any, this makes.

If this has no effect then I'd reset your NVRAM.

Resetting the NVRAM

Your Mac uses Non-Volatile Random-Access Memory (NVRAM). To reset the NVRAM on your MacBook Pro model follow these steps:

  1. Shut down your machine. Yes, a full shut down, so go to Apple > Shut Down so you’re not just logging out.
  2. Press the power button (in your case this is the Touch ID button) and then immediately press the commandoptionpr keys.
  3. Keep these keys pressed down for at least 20 seconds!
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

If you still have problems after doing this, let me know.

Since resetting the NVRAM and swapping the ports has had no real impact, I'd strongly recommend testing your display with another computer and/or trying a different cable.

In terms of the MacBook Pro itself, you could use Apple Diagnostics to test its hardware for some peace of mind. You can do this as follows:

  1. Fully shut down your MBP
  2. Restart your MBP
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

|improve this answer|||||
  • I set my volume to a particular point and also changed my timezone. I tried resetting the nvram several times and I come back to meet same settings. I'm confused on how to do this because I followed the instructions carefully. I just tested it by watching a movie and it just occurred after like 40 minutes. – Collins Aug 9 '19 at 15:12
  • Just to clarify, are you saying that you're not sure if you're resetting the NVRAM properly? Or...? – Monomeeth Aug 9 '19 at 21:38
  • I'm following the instructions carefully and I've tried about 10 more times. I ran csrutil disable in recovery mode and I tried clearing it but I'm getting nvram: Error clearing firmware variables: (iokit/common) not permitted not sure if that error log helps.. – Collins Aug 9 '19 at 22:05
  • I should have asked, do you have a firmware password enabled on your MBP? Also, are you using the built-in keyboard or an external keyboard? And just to clarify your first comment above, what you're saying is that after trying to reset the NVRAM your timezone and sound volume remains unchanged? – Monomeeth Aug 9 '19 at 22:19
  • I do not have a firmware password and I'm using a built-in keyboard. Yes, my volume and timezone remained unchanged and I also wasn't asked to select startup disk(I read somewhere that clearing nvram would cause this) – Collins Aug 10 '19 at 4:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .