0

After the latest update to Mojave 10.14.6, I'm unable to change input source using the keyboard shortcut (it works when I change it by selecting the input source manually).

I tried changing it to different key combinations, rebooting, etc. but nothing works unfortunately. Before the update, everything was working fine.

My question is, is there any known issues/fixes on this? Thanks in advance.

UPDATE

I found out that the control key is causing the issue (Before, I tried only the shortcuts that contained it). I was using ^Space, however, when I change it to Shift+Space everything works fine. Has there been any change to the control key behaviour recently?

  • Shift+Space is not normally a valid shortcut for anything. Are you sure that is what you are using? Is it perhaps Command+Space instead? ^Space is standard for input source switching. What keyboards are you switching between? – Tom Gewecke Aug 13 at 12:46
1

I had the same issue with my mbp after the update. I called Apple support and they said it might be a software glitch that prevent this function from working. The solution I got was shutdown the computer, press the start button and as soon as I let go, press ^control+⌥command+P+R at the same time for 15-20 seconds, and login as usual. It solved my issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .