I am running Xcode 10.3 and I have an iPhone 6s running iOS 12.4. I am unable to connect it to Xcode, which is running atop macOS Mojave running on a VMWare virtual machine.

I got "trust this device" in windows and i can see my device in iTunes in windows. But still cant see it in macos iTunes. Everything has latest versions and my firewall in macos mojave is not on.

migrated from superuser.com Aug 7 at 13:54

This question came from our site for computer enthusiasts and power users.

  • Which VMWare? Fusion, Workstation, Pro/Player? & which release version? – Tetsujin Aug 7 at 14:26
  • Is the iPhone recognized in iTunes in the VM? – Kevin Grabher Aug 7 at 17:45
  • workstation 15 pro – utku cevval Aug 9 at 13:14
  • Is VMWare running on a Mac? – gnasher729 Aug 9 at 19:50

In VMware you have to connect the iPhone as a USB device to the guest virtual machine.

This is usually done from the VMware menu item VM => Removable Devices, where you can select your iPhone. The actual naming of the menu depends on which version of VMware you're using (i.e. VMware Workstation on Windows, VMware Fusion on macOS, or whatever).

  • The problem is I can see my iPhone in removable devices and even in mac's system but xcode cant see in devices when usb is plugged – utku cevval Aug 9 at 13:12

SOLVED-Inside VMWare Setting, Changing USB 3.0 to 2.0 solved it. After this, reconnecting the device to VM made "trust" window appear and the pairing problem is solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .