I have a late 2013 macbook pro running Mojave (10.14.5). When I put it to sleep for a longer period of time (it seems to happen overnight), it restarts after about 8 hours or so. I have no idea why this happens. When I start it back up, it tells me that it shut down because of an error.

This is the output of pmset -g:

MacBook-Pro-van-Robin:~ robin$ pmset -g
System-wide power settings:
Currently in use:
 standbydelaylow      10800
 standby              1
 womp                 1
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 powernap             1
 gpuswitch            2
 networkoversleep     0
 disksleep            10
 standbydelayhigh     86400
 sleep                1 (sleep prevented by CineRenderNEM)
 autopoweroffdelay    129600
 hibernatemode        3
 autopoweroff         0
 ttyskeepawake        1
 displaysleep         10
 highstandbythreshold 50
 acwake               0
 lidwake              1

I have turned off autopoweroff, but this doesn’t change the behavior.

This is the output of log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 24h:

MacBook-Pro-van-Robin:~ robin$ log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 24h
Filtering the log data using "composedMessage CONTAINS "Previous shutdown cause""
Skipping info and debug messages, pass --info and/or --debug to include.
Timestamp                       Thread     Type        Activity             PID    TTL  
2019-08-07 08:01:20.340196+0200 0xaf       Default     0x0                  0      0    kernel: (AppleSMC) Previous shutdown cause: 3
Log      - Default:          1, Info:                0, Debug:             0, Error:          0, Fault:          0
Activity - Create:           0, Transition:          0, Actions:           0

Interestingly, this time it's 3 (hard shutdown), when the previous times it's been 5 (correct shutdown).

When it happened today, it was not plugged in overnight. Battery was at 100% when starting up, though.

I have reset NVRAM and the SMC, but that didn't change anything.

In system preferences > security and privacy > advanced, I have turned off logging out after 60 minutes of activity.

What could be the cause?

  • Do you have an external display connected to your MacBook? This has been a known issue for some people with some LG displays. Aug 7 '19 at 17:49
  • No, no external display connected when I put it to sleep.
    – Flobin
    Aug 13 '19 at 8:01

You must log in to answer this question.

Browse other questions tagged .