I have nothing more to say other than I can't seem to download macOS Catalina beta... it's not available apparently?


I even followed this link, which shows the update in the app store: https://apps.apple.com/gb/app/macos-catalina-beta/id1455661060?mt=12

I have the Feedback app installed and everything, I've restarted my mac and it's the 2019 mac so it's not like it won't be supported. Any help?


You can check if you have a non-standard update source:

defaults read /Library/Preferences/com.apple.SoftwareUpdate CatalogURL

If CatalogURL does not exist, that's OK and the standard situation to pull from the non-beta updates. To force a beta source, you write this key (as root if needed with sudo)

sudo /usr/sbin/softwareupdate --set-catalog https://swscan.apple.com/content/catalogs/others/index-10.15seed-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

Choose About This Mac > Software Update. Wait a moment. An item for macOS Catalina Beta appears.

Screenshot of <code>About This Mac</code> > <code>Software Update</code> > <code>macOS Catalina Beta</code>

You can request an update as well from the command line just as you set the default:

softwareupdate -al

Change the lower case L to a lower case I above and prepend sudo to download and install all updates.

| improve this answer | |
  • Now that the full release is out, will this method work for the final release as well? – A j Oct 30 '19 at 21:21
  • @Ajay yes it will just force your max to retrieve update information from Apple - if your Mac happens to not want to find it. – Nathan Nov 12 '19 at 9:18

This problem has persisted for some users since the release in October. I'm posting it here because Google is referencing this thread.

So, for users in general that get the message "The requested version of macOS is not available"

First, make sure you are not in the beta software program. You will need to log out of that program. For me, that wasn't the issue.

There may be a problem with the sortware update preferences file that keeps track of ignored updates. Go into the terminal and run

sudo softwareupdate --reset-ignored

Then restart your mac, go to software update in system preferences and see if you have the option to install Cataline.

Disclaimer: I'm not smart enough to have figured this out. Thanks to Apple support. I had the same problem as everyone here. So on a lark I went to the Apple website, clicked on downloaed problems. Within seconds I get a call, then go on hold for 30 seconds or so, and this really nice and really patient Apple support staff is on the line. On a Sunday!!! We walked through the problem, repeating steps. Once the softwareupdate utility was run it was fixed. Yippee for Apple support!! If this had not worked he said he would have done the network install others have described. ( Command-Option-R )

| improve this answer | |
  • This worked for me, I am now on Catalina. Thanks. – A j Nov 12 '19 at 22:19
  • There is no need to restart your mac. – ajmccall Jan 21 at 11:53

What worked for me was leaving the MacOS public beta program. I had already removed the profile, but ran into the problem described above. Leaving the program (on the website, https://beta.apple.com/sp/betaprogram/login_to_unenroll#macos) immediately fixed it.

| improve this answer | |

For me I was stuck with a terminal that refused to open. I ended up deleting the previous beta installer I found on the second page of the launch pad. Once I deleted it and then re-ran the macOSDeveloperBetaAccessUtility.pkg file again I was able to download and install the newest beta.

| improve this answer | |

Another possible reason for this error: If the Mac in question is enrolled in an MDM and has a Configuration Profile with a Software Update payload, that profile seems to take precedence and the macOS Beta Profile isn't applied.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .