1

I disabled some ports (below) to be able to install Adobe Photoshop/Illustrator applications. The challenge is to re-enable them through terminal, otherwise I could not install Photoshop( see below picture ).

It can be run with simple sudo sh >filename<

This file contains this bash command:

echo "Do you wish to update your host file ?"
select yn in "Yes" "No"; do
    case $yn in
        Yes ) echo "127.0.0.1     activate.adobe.com" >> /etc/hosts;
              echo "127.0.0.1     practivate.adobe.com" >> /etc/hosts;
              echo "127.0.0.1     lm.licenses.adobe.com" >> /etc/hosts;
              echo "127.0.0.1     lmlicenses.wip4.adobe.com" >> /etc/hosts;
              echo "127.0.0.1     hlrcv.stage.adobe.com" >> /etc/hosts;
              echo "127.0.0.1     na1r.services.adobe.com" >> /etc/hosts;
               break;;
        No ) break;;
    esac
done

It needs to reenable because it can not allow installation from this point: ADOBE SETUP

Does anyone know what commands are capable to reenable them? Or are there any programs to do it automatically?( It should be there because later I found an automatic program which - then - solved this challenge but now I could not enable it.

1

Not by commands/ scripting, but to solve the issue:

Open the file /etc/hosts by pasting it in "Go to Folder" in Finder. Edit out anything related to Adobe. This would stop redirecting those urls to 127.0.0.1 which is localhost. Thus allowing connections to actual IP. In my file, localhost, broadcasthost are there only.

Also, for unknown errors/causes, https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html is helpful.

1

The answer is that:

At the private/etc folder we can find the file: hosts This includes all the infos if a specific url ( in this case adobe) are redirected.

It looks like this:

127.0.0.1   localhost
255.255.255.255 broadcasthost
::1             localhost 


127.0.0.1     activate.adobe.com
127.0.0.1     practivate.adobe.com
127.0.0.1     lm.licenses.adobe.com
127.0.0.1     lmlicenses.wip4.adobe.com

The second part of the file's .adobe.com (or other relevant urls) need to be deleted and saved.

You can open a file with terminal

sudo open hosts 

first it needs to be unlock(from the upper part of Textedit or in Get Info) and after save it and Lock it.

This is the right answer thanks to ankiiiiiii

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .