0

I followed this guide to make iTunes store my iPhone backups on my Time Capsule drive, which has free space to spare instead of my MacBook, which is low. However, when I run a backup now, I will get the following error message:

"iTunes could not back up the iPhone because an error occurred while reading from or writing to the iPhone." enter image description here The backup process clearly writes to the disk as I can see the many GB worth of files reside in the correct place. So the symlink works for that, at least. It just fails on step 5 of 5 of syncing in iTunes, "waiting for changes to be applied". That's when the above error message is given. I have tried both doing a clean backup into the Time Capsule and relocating my current backup thereto and then doing an updated backup.

I suspect it may something to do with permissions so I also tried allowing Airport disks guest access using an older version of AirPort Utility (5.6) but it didn't help either. So does anyone know of a way to backup directly to the Apple Time Capsule? Thanks

1

Thanks for checking that some of the files show up to ensure the symlink works.

The first thing I'd try is to keep your Finder window open to the time capsule folder where the backup is being written, in case some power-saving mechanism is disconnecting from the Time Capsule. Even better if you can occasionally remember to navigate around to really make sure that connection is still active.

  • I have tried keeping the Finder window open and also navigating from time to time and I also have tried doing the backup while the Time Machine backup was being made to the same Time Capsule, so, I think I can eliminate any power saving mechanisms. – yssup Aug 4 at 19:22
  • Ok, let's dig in and see what the error messages. Open the Console app and select your iPhone, then filter the messages by (process) BackupAgent2. If you're on an older version of macOS or need more helps to get the console app open, you can reach me here: deciphertools.com/support.html :) – Kelly Aug 5 at 20:41
  • nothing about BackupAgent 2 is found when I do what you proposed. Shouldn't I let the error appear and then try to capture the BackupAgent2 message in Console? – yssup Aug 15 at 20:33
  • Yes, I would try making the backup again and see if you get new log messages about BackupAgent2 (all one word). – Kelly Aug 15 at 21:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .