I want to record some audio from my A/V receiver. It has Toslink output, so I want to use that. I plugged a Toslink cable into that (I can see the red light!), and plugged the other end into a toslink-to-mini-toslink adapter, and plugged it into the "line in" port of my Mac.

Unfortunately, it doesn't seem to do anything. In the Sound control panel, even with the Input Volume turned all the way up, the "Input Level" shows nothing at all. In Audacity, recording just records empty silence.

I have two Macs, and the behavior here is exactly the same on both. One's an Intel Mac Mini Core Duo ("Macmini1,1"), and the other's a Macbook Core 2 Duo ("MacBook2,1"). According to the spec sheets, both have Toslink input. I frequently use Toslink output on both Macs using this cable.

I've recorded audio onto both Macs using analog audio cables and Audacity before many times. Is there anything special I need to do to enable Toslink audio input?

1 Answer 1


Just to be sure:

You mentioned checking the Sound control panel on the Macbook input side (I assume you selected Line In as well), but what about the output device on the Mac Mini? Plugging in the cable usually switches system output to Line Out, but not necessarily the output of whatever application you are using. So check both the Sound control panel output and the settings of your playback application (if it has any).

Also make sure the TOS connecter seats all the way (usually with a click). The Line In defaults to analog and, IIRC, it only switches to TOS if it senses a non-conductive plug clicking on some little switch.

  • The audio signal is coming from my receiver, not another Mac. (I also tried plugging it into my DVD player directly, which is the original source I'm trying to record.) I can clearly see a red light coming from the cable, so I assume there is a signal there.
    – Ken
    Jan 13, 2012 at 17:08
  • I tried plugging in the cable a couple times, with no improvement. I use the same cable for Toslink output from the port right next to this one on the same Mac, so I'm fairly certain it's seating properly.
    – Ken
    Jan 13, 2012 at 17:09
  • 1
    The red light means the link carrier is active, but its possible the device needs to be told to output to Toslink. That seems unlikely, but is worth checking. Something else to check on the Mac is /Applications/Utilities/Audio Media Setup.app to see if Line-in is fixed to analog for some reason.
    – Seth Noble
    Jan 13, 2012 at 18:20
  • I might have to write to the maker of my receiver. It seems odd that it would activate the "link carrier" but not put a signal on it, but I suppose it's possible. I don't see any obvious settings here to enable it.
    – Ken
    Jan 15, 2012 at 1:44
  • I have an "Audio MIDI Setup" app (this is OS 10.5.8). There's nothing I see to suggest it's being told to use analog only. Good idea, though.
    – Ken
    Jan 15, 2012 at 1:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .