I recently tried installing DisplayLinkDriver on Mojave 10.14.5. However, the security prompt to authorize it did not appear in my system preferences. I tried uninstalling and reinstalling DisplayLinkDriver to verify if this would produce the propmt. However, this did not fix the problem.

I then attempted to manually install the driver via kext. However, my attempts were unsuccessful because DisplayLinkDriver is listed as disabled.

I noticed that uninstalling DisplayLinkDriver using the uninstall tool did not remove it from the Disabled Software list. I am wondering if there is a way to manually remove it from the Disabled Software list or mark it as enabled?

enter image description here

  • While the question arose from an uninstall failure, the question is actually related to modifying the Disabled Software plist. I think this is improperly labeled. – Floam Aug 5 '19 at 15:07

The safest way is to use our uninstaller. If you have partially uninstalled you'll have to run a complete installation before uninstalling. The uninstaller is in the /Applications/DisplayLink folder.

Depending on your upgrade history you may have slightly different files but if you really want to uninstall manually -again not recommending that- here is the list of files: OSX 10.10.x:

  • /Library/Extensions/DisplayLinkDriver.kext
  • /Library/Extensions/DisplayLinkEthernetDriver.kext
  • /Library/LaunchAgents/com.displaylink.useragent.plist
  • /Library/LaunchAgents/com.displaylink.useragent-prelogin.plist
  • /Library/LaunchDaemons/com.displaylink.launchd.plist
  • /Library/LaunchDaemons/com.displaylink.displaylinkmanager.plist
  • /Applications/DisplayLink/DisplayLink Software Uninstaller.app
  • /Library/Application Support/DisplayLink
  • /Library/PrivilegedHelperTools/DisplayLink
  • /var/db/receipts/com.displaylink*

Administrator access is required.

On 10.8 the kext files are in /System/Library:

  • /System/Library/Extensions/DisplayLinkDriver.kext
  • /System/Library/Extensions/DisplayLinkEthernetDriver.kext

From: https://www.displaylink.org/forum/showthread.php?p=76864

  • This again does not work. I already mentioned in the question that I went through the uninstall process (which removes references to DisplayLink from the folders you mentioned). I also doublechecked the folders that you listed. All of those folders do not contain anything related to DisplayLink driver. The issue is that the driver is referenced in the Disabled Software plist. I am unsure how to remove it from that plist. This is not handled by the uninstall tool and the suggested changes that you listed. – Floam Aug 5 '19 at 14:59
  • This is the folder that triggered it for me. /Library/PrivilegedHelperTools/DisplayLink – Thomas Nelson Aug 6 '19 at 0:07
  • There is no reference to DisplayLink in my /Library/PrivilegedHelperTools/. I think you are missing the point of the question. The question asks how do you remove an item from the Disabled Software plist. Let's not focus solely on DisplayLinkDriver's uninstall tool which is not working. – Floam Aug 6 '19 at 13:29
  • @Floam... You have to remove the file. This is not windows, there is no registry to remove things from. The list is built dynamically. – Thomas Nelson Aug 6 '19 at 23:52
  • Thomas, the file was removed. I even restarted. This doesn't prevent the above from being removed from the Disabled Software plist. – Floam Aug 9 '19 at 3:33

I have managed to get it working again. Here are the steps I had to go to:

  1. Uninstall the DisplayLink drivers and restart the system.
  2. Right after restarting the system, reinstall the drivers. Don't restart again yet.
  3. Open System Preferences -> Security and Privacy. If you did that right after reinstalling the drivers, you should see a message saying that an extension was blocked. You should know what to do now.

The message on step 3 only was displayed to me immediately after starting the system.

  • This doesn't work. The issue is that it is stuck in Disabled Software. Consequently, that button doesn't appear. See the last line of the post. – Floam Aug 2 '19 at 16:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .