1

Today I moved a folder (a folder I created myself that contained video files) from my HD that was almost 100GB in size to an external HD (I don't use Time Machine/never have) and once I ejected the external HD I moved the original folder to the trash and emptied it. This was about 8+ hours ago and the space is still not freed up on my HD.

I already tried re-indexing spotlight and that didn't help either. I am out of ideas. My HD is showing as having 10 GB of free space when it should be around 110 GB of free space. I've also re-started my computer several times.

I run Mac OS X El Capitan 10.11.6.

ETA: I can delete other files now (like I just deleted a smaller 3 GB file and that bumped my free space up to 14 GB but how can that be possible? It's like the huge folder I deleted never actually cleared but smaller files are being cleared.

  • At such high sizes, there is a possibility that confirmation boxes would appear. Either password or just a confirmation. Can you check your original folder location once again ? – ankii Aug 2 at 3:53
  • 2
    you should see the disk structure or files with the help of software at How can I figure out what's slowly eating my HD space? – ankii Aug 2 at 3:54
  • Have you double-check the external HD to see what in fact has actually been copied there? And, assuming it's all there, check to see how much space it takes up? – Monomeeth Aug 2 at 7:44

You must log in to answer this question.

Browse other questions tagged .