14

macOS Catalina has a feature where you can use your iPad as a secondary display for your Mac. I have a Macbook Pro 2016 and a 10.5 inch iPad Pro 2017. Both are officially supported for the latest versions of macOS and iPadOS and support Sidecar.

I installed the latest version of iPadOS and macOS and tried using Sidecar and it kinda works but it's extremely laggy and blurry and almost unusable and if I turn wifi off in my mac it disconnects and complains about wifi being turned off.

As far as I know this feature can work with wired connections as well and I tried connecting iPad to Macbook using a (Lightning -> USB A) to USB C adapter and also also tried using a USB 3 hub connected directly to the laptop using USB C and it still does not work.

Is there any way I could force Sidecar to work over a wired connection?

  • 1
    Did you try a direct Mac-iPad connection (without any adapters or hubs)? – nohillside Aug 1 '19 at 9:31
  • @nohillside I don't have a Lightning to USB C cable. My USB C hub is actually part of the monitor stand and connects to the laptop with a DisplayPort over TB3 connection. – Vahid Amiri Aug 1 '19 at 9:35
12

I struggled with the same problem and just now finally solved it. The issue was for me that I didn't earlier "Trusted my iPad" on my mac, and "Trusted my Mac" on my iPad. Here's a how to: https://support.apple.com/en-us/HT202778

After doing this, it finally connects via cable and is hopyfully less buggy. x'3

| improve this answer | |
  • This is the right answer! I'm surprised this doesn't have 100 upvotes. – Xster Feb 16 at 22:18
  • Support article on trust is lacking important details for my setup. Using Finder to establish Trust (Sebastien's answer) worked for me. – Leopd May 12 at 16:22
6

For anyone stuck with the same problem, I figured out that I needed to Trust the ipad on my Mac by opening a Finder window, click the ipad on the left bar and finally "Trust" with the appropriate button on the right.

| improve this answer | |
  • took me almost 2 hours to find this...damn apple – Jose Pita Apr 6 at 9:25
  • There is no ipad icon on the left – KSPR May 4 at 10:34
  • You might need to open Finder > Preferences > Locations and select "CDs, DVDs, and iOS devices" – Leopd May 12 at 16:18
3

You can use a direct USB-C to Lightning cable (I used an MFi cable by Aukey). Turn off the iPad's wifi, make sure you are signed in to the same apple ID, have iOS13 and Catalina installed. It is much faster than the wifi connection for me (and I also have less lag on my mac this way).

| improve this answer | |
  • 1
    My iPad 12.9 connected via USB-C would not connect unless I gave it the Wi-Fi connection. By turning off Wi-Fi on the iPad itself, then using sidecar, I could finally connect over USB-C. Thanks! – William Cerniuk Nov 20 '19 at 12:40
  • I tried this with an iPad Mini (2019) and MacBook Pro (2018) – didn't work. – adib Dec 1 '19 at 3:24
2

For me, it wasn't a cable issue and the "Trust this Computer" fix didn't work either. I finally found an answer on the Apple Support Communities that fixed the issue for me. Here's an excerpt of the relevant section:

Following the instructions, I noticed there were two .plist files in particular that looked suspicious:

/Library/Preferences/SystemConfiguration

preferences.plist contained a reference to "iPad USB" (even though I didn't see iPad USB in my "Network" settings).

NetworkInterfaces.plist contained multiple references to "iPad".

I made a backup of the two .plist files, deleted them from the SystemConfiguration folder, and rebooted. Voila! Now Sidecar works over USB.

Note: Both my Mac and iPad have WiFi completely turned off. Both have Bluetooth turned on. Mac is on Ethernet. iPad is connected to Mac using USB cable. That's it.

I am not a Mac expert, so I can't advise on the two .plist files I deleted. It worked for me, but your mileage may vary, and I am not sure if there is any danger related to deleting these files. Another thing I am not sure of, is whether it was necessary to uninstall ExpressVPN AND delete the .plist files. I wonder if doing the latter is sufficient to get USB Sidecar to work.

| improve this answer | |
  • Doesn't help at all. – KSPR May 4 at 10:33
  • It worked for me. Check the device trust first, and if that doesn't get Sidecar USB to work, fix the .plist files as mentioned above. Also make sure no VPN connection is active when connecting Sidecar USB. – YYL Jun 19 at 3:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .