2

On a MacBook air, the trackpad is super hard to use because whenever I try to move the cursor, it selects everything or drags something to somewhere random. This is the fault of some tap to drag feature. Whenever I touch the trackpad and move my finger, it thinks I am trying to click and drag. I disabled tap to click and everything, but this feature still vexes me. This feature is a pain in the butt so how can I disable it?

  • 2
    Try going to System Preferences → Accessibility → Mouse & Trackpad → Trackpad Options..., and look for Enable dragging setting. Try changing from with drag lock to three finger drag. – Nimesh Neema Jul 31 at 16:44
4

If this is a newer MacBook Air (with a Force Touch trackpad), changing the pressure required to "Click" should help fix this. I experienced similar issues on my MacBook Pro.

Go into System Preferences, click the Trackpad icon, and select the "Point & Click" tab. On the left you should see a "Click" slider with "Light", "Medium", and "Firm" options. If you shift it over one setting, you might find that's enough to fix the issue.

Alternatively, disabling Force Click and haptic feedback (unchecking the checkbox at the bottom), may also stop peculiar behavior from happening. That's ultimately what I ended up doing and it made a world of difference in my case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .