2

I have an IKEv2 VPN set up in my network preferences. It works fine, I can access any desired computer in the remote network by the IP. Also, I added our DNS server to the VPN connection though Advanced tab, as well as the Search Domain. The DNS server works also well.

The problem is, the DNS does not work at after I connect to the VPN. I can ping the DNS server, I can dig the server, but OS X does not reflect it at all.

  • The DNS server is not listed in scutil --dns.
  • dig <hostname in VPN> @<IP of my DNS server> returns correct answer

I wrote about this problem in another post here.

Why it does not work? What I am doing wrong?


To be honest, I'm starting to be sort of frustrated about this, because, according to Google, it seems like this never worked for anyone and this topic appears to be very ungrateful for some reason. Is this a bug/feature of OS X or what?

  • 2
    From what I know IKEv2 doesn't push DNS settings so the VPN connection may be ignoring it. You can set the DNS settings and because they don't work then that is a bug. Let me know how you fixed it if you find a fix. We hard coded the server IP in our clients to get our stuff to work. – Thomas Nelson Jul 31 at 1:02

You must log in to answer this question.

Browse other questions tagged .