• iPhone Xr
  • iOS 12.4
  • Gboard
  • Gmail 6.0.190602

  • Docs 1.2019.28202

  • Chat 0.156.259040960

Issue: I various apps developed by Google, such as Gmail, Docs, Chrome, Chat, the Gboard keyboard is not appearing. Nor is the "globe" icon that should allow one to switch between keyboards. Instead, I'm left with only the basic keyboard.


GMail Docs Settings

Things I've tried/reviewed:

  1. Reinstalling the apps where I'm seeing the issue
  2. Reinstalling Gboard
  3. Restart of iPhone
  4. Tapping where the "globe" should be
  5. Within Settings, rearranging the Gboard keyboard to not be the default
  6. Within Settings, confirmed that the Gboard keyboard has Full Access
  7. Ensured all individual apps, as well as iOS itself, are up to date

Has anyone experienced this issue or have any suggestions of what else to try to resolve this?

2 Answers 2


I'm having the same issue and like you I've tried everything from reinstalling to trying different custom keyboards. Only the default keyboard and emoji keyboards work in the google apps like gmail, hangout, meet etc. I can't find a lot of people complaining about the issue online so I figured it might be because this is a company device and some permission is blocking it? The custom keyboards work in all other apps so gboard not working with google apps is just baffling.

  • Looks like my suspicions are correct. Are you using a managed device? Look at the last point in this article. support.swiftkey.com/hc/en-us/articles/…
    – Satya Bhan
    Sep 4, 2019 at 19:13
  • Hi! welcome to Apple.SE! you can always edit your own post using the edit button.
    – anki
    Sep 4, 2019 at 19:37

The root cause of this issue ended up being related to a corporate MDM that's tied to the device. Luckily this app is approved by corporate. However, to resolve, I needed to uninstall the Gboard app I had downloaded from Apple's App Store. I then needed to re-install the app from my corporate's "App Catalog." After taking these steps the Gboard keyboard appears in all apps as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .