13

I have scrolling problems very often with the calendar app on macOS. It works "a bit" but get stuck into the current week, scrolling left or right will just bump but not scroll, driving me insane.

You can see something about that here: https://discussions.apple.com/thread/7954399

enter image description here

Although the solution enunciated there works, it's very inefficient and boring procedure to do.

1
  • Could you please summarize here what the linked fix is? I don’t see it there, thank you.
    – 2540625
    Feb 25, 2023 at 19:37

3 Answers 3

15

A stupid and so simple solution, which for months (if not years...) I didn't think about, is simply to right click in the calendar app (with the same two fingers you use to scroll).

And that's it, problem gone!

4
  • 4
    This was stupidly simple and worked for me too in MacOS Monterey. Bug was driving me nuts! Crazy. I'm sure a reboot would have worked too, but now I can delay the inevitable, haha. Thanks!
    – purefusion
    Apr 29, 2022 at 11:36
  • 2
    This works for me too on Monterey. But how did you even discover this and why does this work lmao
    – RexYuan
    Aug 30, 2022 at 9:44
  • 1
    Thanks so much! That bug was also driving me crazy. I had even restarted the calendar app! Oct 23, 2022 at 11:03
  • Yeah even restarting Calendar.app didn't work, but this did. Some weird kernel/ driver bug it feels like
    – ijoseph
    Oct 30, 2022 at 20:45
9

Rebooting works for me, though I'm glad to learn the workaround you linked to.

For posterity, the workaround was to go to:

System Preferences > Accessibility > Mouse & Trackpad > Trackpad Options...

and toggle the scrolling settings and shown in the picture.

enter image description here

UPDATE FOR VENTURA 2022+:

System Settings, Accessibility, Pointer Control, Trackpad Options…, and toggle off/on Use trackpad for scrolling.

enter image description here

2
  • Thanks! This works for me in macOS Ventura, combined with right clicking the calendar app as described in another answer. In macOS Ventura the setting is at System Settings > Accessibility > Pointer Control > Trackpad Options > Use inertia when scrolling.
    – intagli
    Nov 25, 2022 at 10:24
  • 1
    Fixed month view not scrolling for me on macOS 13.1 (Ventura) by toggling "Use trackpad for scrolling"
    – malhal
    Dec 14, 2022 at 14:15
0

For the trackpad I see the selection box to tick on scrolling - but not for the mouse ... see picture.enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .