46

(I am on macOS 10.14.6 and iOS 12.4)

  1. I am certain that I have trusted my Mac before.
  2. Without the latter trust, I can also access the phone in iTunes.

I have tried reset "Location and Privacy" on my phone. Then

  1. When connecting the iPhone with iTunes running, it asks for the trust and I trust it.
  2. Reboot my Mac and the phone asks for another trust.

Is there some known malware mimics system behavior and steal data from an iPhone?

(I do have installed some pir*ted software recently. That's my fault.)

0

10 Answers 10

49

Personal Hotspot being "on" while connecting the USB (tethering) seems to be the issue. Turn it off, connect the cable and turn it back on if required.

If you just need to use the hotspot and not bother about syncing iPhone using iTunes/Finder, then enter passcode once, & tap "cancel" or "Don't Trust" second time onwards and you will not face any problems.

5
  • 14
    Is it possible to have personal hotspot on and not have to deal with this issue?
    – Toland H
    Jan 10 '20 at 22:18
  • I had it off, but just turning it on and off again fixed it. Jul 7 '20 at 14:09
  • 1
    @TolandH see the update
    – anki
    Jul 24 '20 at 20:43
  • Can confirm this is the case for me.
    – ortonomy
    Aug 6 '20 at 12:22
  • @IulianOnofrei - thank you. That was the thing for me.
    – dgo
    Jul 21 at 18:30
39

NOTE: See the edit history if you're curious on updates / timing of this

To clean up from this - you may have to both update iOS / macOS and perform operations on /var/db/lockdown that are more complicated than removing a folder / file.

On to the story of how we learned this...

I've been working with AppleCare on this issue for about 2-3 months now. The Apple engineers have confirmed to me that they can replicate the trust dialog box issue when the iPhone's Personal Hotspot is enabled, and connected to a Mac using Apple's official USB-A to Lighting cable. I believe that they replicated this using the same operating system as the one running on my MacBook Pro (macOS Mojave 10.14.6). So I'm not sure if it affects macOS Catalina, but I will be testing that shortly myself.

They are still investigating, but they said they're unlikely to patch up older operating systems. So I'll get back when I know more.

Some things to note in my case:

  • This is all happening with completely new and old Apple's official Lighting cables, but none of my cables have wear and tear, so unlikely to be a physical connection issue. Especially since they also can replicate it.

  • Resetting Privacy settings on the iPhone deletes the trust relationship with a computer, so after resetting this, it will prompt you to trust your computer next time it is connected via the Lighting cable.

  • Interesting to note, when it's prompting you to trust your computer for the first time, it will say:

    "Your settings and data will be accessible from 'Name's MacBook Pro' when connected wirelessly or using a cable".

    But after trusting it and connecting it again with personal hotspot enabled, it will say:

    "Your settings and data will be accessible from this computer when connected wirelessly or using a cable".

  • Additionally, after the initial trust between the iPhone and the Mac, the Mac writes a plist file in the /var/db/lockdown/ folder, which is titled your iPhone's UDID.plist.

  • This plist file is used each time your iPhone and Mac are connected via the Lighting to USB connection, to check that the devices have trusted each other. If the plist is missing, the Mac will prompt you to trust it from your iPhone before iTunes will recognise it.

  • Deleting the iPhone's associated lockdown plist file on the Mac, has the same function as resetting your iPhone's privacy settings (but on the Mac-side).

  • It's a bit more difficult to delete it, requiring SIP to be disabled and entering into Rootless. So unless you are very confident in working in rootless, there's not much point, as resetting Privacy settings on the iPhone has the same function. After resetting iPhone's Privacy settings and trusting your Mac from your iPhone, the old plist file is overwritten by a new one in the Lockdown folder.

  • Finally, I've noticed that if the iPhone and Mac are connected via the Lighting cable, and I disable or enable Personal Hotspot on my iPhone, there is a very quick disconnection/reconnection between the devices. I notice this on iTunes and can see it in the Mac's console log event messages.

The only solution so far is to ensure Personal Hotspot is disabled in the Settings app. Note that disabling the Personal Hotspot in the iPhone's Control Centre is not enough, as that just sets the discoverability off. You need to go to the Personal Hotspot settings in the Settings app to fully disable the hotspot.

As I said, I am unsure what the cause is, but I will update here when the Apple Engineers get back to me. But I hope this provides you all some additional information.

Please note this is my first time posting on Ask Different stack exchange, so I hope this post meets all the community guidelines :)

UPDATE 18 February 2020

I've just had a call from AppleCare. The Engineers have confirmed this is a bug that can be replicated on macOS Catalina 10.15. The Engineers have now escalated this to their senior Engineers to develop a bug fix.

As this is now out of the hands of my AppleCare Mac Specialist, my case has been closed, so it's unlikely I will receive any further updates on this issue. However my AppleCare Mac Specialist said "you've found a bug, and now we're going to fix it", so hopefully they will do this.

If I do get any further updates, I will post here.

UPDATE 18 September 2020

I've updated my iPhone XS to iOS 14 yesterday, and after testing various different scenarios, the issue no longer appears to be happening with or without the hotspot activated. Note, I have only tested this on macOS Mojave 10.14.6, so I cannot guarantee it has been fixed for earlier macOS versions, but suspect it has been fixed for at least Catalina and Mojave. I will continue to monitor this just in case it does develop again.

I'm glad that a longstanding bug has been finally fixed and hope that my reports to Apple had contributed to this being fixed. Now if only Apple could fix the usbd bug that causes connection issues between iPhones and Macs (mainly MacBooks) which I have described elsewhere on this forum...

Please let me know if you still experience this issue with iOS 14.

Hope this helps everyone!

8
  • 4
    Many thanks for the updated answer. You have probably saved many people a lot of time.
    – jdm2112
    Feb 20 '20 at 17:09
  • "you've found a bug, and now we're going to fix it" -- that's more than most people get. Did I understand correctly that the bug is in macOS and not iOS?
    – Andreas
    Feb 24 '20 at 13:49
  • @Andreas We're not sure at this stage, but all the testing was done by the Mac Software Engineers using my Mac and their internal Macs. Personally I think it's macOS not letting the iPhone communicate to the Lockdown folder. I'll keep you updated if I get any further information (albeit doubtful they'll individually respond to me, since the case is now closed).
    – AVelj
    Feb 25 '20 at 5:58
  • 2
    One of the best answers about an obscure condition with macOS and iOS devices I have ever read. Great detective work and great write up. Apr 23 '20 at 3:01
  • 1
    @JakeGould It's was a very very frustrating experience trying to resolve this issue... Although no fix has come out yet, I hope it will get fixed in some future update. My investigations into this issue had originally stemmed from another (possibly related) issue, which I've described here: apple.stackexchange.com/questions/382002/… If anyone has any ideas, please let me know :)
    – AVelj
    May 18 '20 at 0:00
9

The following worked for me. This is from https://macreports.com/iphone-keeps-connecting-and-disconnecting-from-mac-fix/

On the Mac, open the terminal,

 sudo killall -STOP -c usbd

Or use Activity Monitor to kill the process.

This will restart the USB daemon on Mac. After this, my phone asked for 'Trust' only once.

6
  • 1
    Pausing the usbd process doesn't stop this bug, but it does stop a connection issue bug other users have reported, (which I have documented this myself here: apple.stackexchange.com/questions/382002/…). I can confirm even with the usbd process stopped, the trust dialog still appears upon each reconnection. The only temporary solution is to disable personal hotspot (as I've documented in my answer above) for the trust dialog box to stop appearing.
    – AVelj
    Jul 25 '20 at 6:18
  • 1
    Works for me, thanks
    – Jhegs
    Aug 15 '20 at 2:29
  • It Worked like charm to me, thank you very much
    – Saurav
    Oct 28 '20 at 20:00
  • OH! THANK YOU!!! I've got this problem for years when starting Xcode and I new it's something wrong with USB + Xcode. I've made script out of it cuz this annoying problem for sure comes back soon. After running this command everything works super! MacBook Pro (Retina, 15-inch, Mid 2015) Big Sur (past versions like Mojave, Catalina, High Sierra, Sierra... also got this problem) Jan 8 at 12:51
  • worked for me - thank you! Jan 28 at 0:59
5

I used to have this issue in the past before, and for me the cause was faulty lightning cables. Make sure you're using genuine cables from Apple and not third-party ones. This might not be the same solution for you but try it out and I hope it helps!

1
  • 1
    Same here, except I saw it with a damaged genuine cable. Switched to a different cable and the message went away.
    – Jawann
    Aug 16 '19 at 8:31
1

Yes there are malware which mimic iOS window which origin isn’t clear, but all of these malware are either asking user an account and a password or providing a link to click (which link will connect the user to a booby trapped server).

No you weren’t facing a fake window in this case even if the origin of the window isn’t given. This window doesn’t try to steal you any private information.

This is just a poorly designed confirmation of trust window which should be named iTunes sync or something approaching. This is also probably an old bug when the connecting iPhone and Mac are well known friends.

I found many log entry of my iPhone which are accessible in Settings > Privacy > Analitics. But I still have to find a tool to analyze them.

1

I believe "trust issues" can be caused by flakey or failing cables. My eventual solution after all manner of troubleshooting was purchasing a new original cable.


For some explanation, I too have had this nagging issue for a couple of weeks now. After trying everything I finally tried a different (brand new) cable (both are original apple cables, but the old one I have used for many years and has signs of wear at the connector). With the new cable it stopped asking me to Trust. Plug the old cable in and I get the Trust question again. So the cable seems to be the issue; nothing else has seemed to work. (Mac is an old Mid 2012 Pro on Catalina 10.15.3 and the phone is an 8 with 13.3.1 iOS).

0
1

For what it's worth, I have found that when the keypad appears, rather than entering the numbers, if I just hit cancel, the Mac is back in the good books, but it still happens every time.

And for what it's worth again, on at least one occasion, I was not prompted to trust the Mac, but I am unable to replicate the exact circumstances again; programs running, settings, facing north, the colour of my socks etc. I sometimes connect via USB, and sometimes wi-fi. It never asks when connecting via Wi-Fi, only USB. And as I said previously, if I just hit cancel when prompted for the passcode . . . at least I don't have to do the button boogie. BTW: I was a little surprised that Apple didn't sort this with the latest iOS. G

0

In my case, I was using Non-ASCII characters for the Macbook name. After renaming it by using the only alphabets, the irritating popup disappeared.

0
  1. Disconnect All Devices connected with USB to your MAC, then

  2. Goto Terminal

  3. Run below two commands -

    a. sudo killall usbd

    b. sudo killall -STOP -c usbd

1
  • How is this answer different from the answers already provided? This repeats info in a previous answer.
    – fsb
    May 25 at 12:35
-1

Have you tried connecting the device, trusting it and then unplugging it and repeat.

1
  • welcome to the site and thanks for the suggestion! We've tried it and the bug can be redone multiple times.
    – anki
    Sep 10 '20 at 14:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .