0

After I sent an email multiple copies of the same email appear in the sent folder as if I was manually sending the email every time after I wrote a few words in a sentence. Since nobody is complaining that they are receiving incomplete copies of the same email from me I'm guessing those are drafts, but why is Mail saving all those drafts in the sent folder? Can I disable that behavior? and how can I remove the existing copies without deleting the "actual" email that was sent?

  • Are your Mailbox behaviours for the concerned account in place ? Is it a work mail ? – ankii Jul 27 at 16:46
  • @ankiiiiiii I hadn't changed those, I guess their values were the default ones. But, now I've put all accounts in the option On My Mac > Draft. All are personal accounts (iCloud, Google, Yahoo) except for a couple of IMAP accounts that are from work. – rraallvv Jul 27 at 18:32
  • If that solves it, you should put up an answer :). if not, update the question – ankii Jul 27 at 18:47
  • @ankiiiiiii will do! – rraallvv Jul 27 at 19:07

You must log in to answer this question.

Browse other questions tagged .