0

I recently bought a Synology NAS. I can mount via SMB and APS properly, but I can't make hard links. So I looked around and tried to use NFS. NFS ver3 does work, but Finder behaves strangely for some folders as if that folder can't be retrieved or the drive has freezed, but in terminal everything worked fine (note: using ffplay to play the file in the folder succeeded, but 'open' says that there are no such file). Then I realize that I can mount using NFS ver 4.1 as the NAS supports it. But then I run into this issue. The command I use to mount it is as follows:

nfsver 3: mkdir /Volumes/File mount_nfs -o rwsize=32768 -o locallocks -o namedattr -o noac -o rdirplus -o nfsv3 jin.local:volume1/File/ /Volumes/File

Output: mount_nfs: option nfsv3 deprecated, use vers=#

nfsver 4: mkdir /Volumes/File mount_nfs -o rwsize=32768 -o locallocks -o namedattr -o noac -o rdirplus -o nfsv4 jin.local:volume1/File/ /Volumes/File

Output: mount_nfs: option nfsv4 deprecated, use vers=# mount_nfs: can't mount volume1/File/ from jin.local onto /Volumes/File: Invalid argument


NFS ver 4.1 is enabled

enter image description here

  • I had tried without all argument but that don't solve the issue. – Joy Jin Jul 27 at 9:00
  • I do not think macOS support v4 of nfs. You should look into downloading v4. try brew. I do not think you can use hard links on networked volumes. – historystamp Jul 27 at 19:34
  • @historystamp It does. macOS doesn't support v4.1 though. Look at the man page of mount_nfs. NFS supports hard link, I think. – Joy Jin Aug 9 at 0:33

You must log in to answer this question.

Browse other questions tagged .