0

My new iMac (July 2019) keeps crashing and I'm in need of assistance:

I've had 7 incidents in two weeks:

  • Four times when starting Final Cut Pro X I get a forever beachball.
  • Two times when starting Wine app (a windows emulator) I get a forever beachball.
  • One time when starting MacOS I got a forever beachball.

Each time I'm unable to shutdown or restart the computer afterwards. I get a grey "wheel" as it's shutting down that never finishes. Forcing me to shutdown with the physical power button.

I tried resetting PRAM & SMC. And I downloaded Etrecheck and ran it the next time I started FCPX and got a beachball. But then Etrecheck got stuck in a loop as well and never finished the report. So I was forced to restart (with power button) and I was able to run an Etrecheck report on startup (see below).

I then did a Safe Boot. And a Recovery Boot, where I ran Disk Utility's First Aid 3 time, getting an OK.

What are my options? My fear is that it's a hardware issue and that I need to contact Apple and return the computer (after spending two weeks setting everything up). I don't live close to a store and don't have a car. Hopefully it's a software issue that I can resolve somehow. Asking for this community infinite wisdom. Thank you!


Here's a screenshot of Activity Monitor when app stalled:

enter image description here


And here's an Etrecheck report made after crash, at startup:

EtreCheck version: 6.0.2 (6A004)
Report generated: 2019-07-26 02:55:02
Runtime: 1:25
Performance: Excellent

Problem: Beachballing

Description: 
1 out 4 times apps like FCPX (and wine) beachballs and if I try a restart 
there's a spinning grey wheel. Forced to close down with holding down 
power button.

Major Issues:
    Anything that appears on this list needs immediate attention. 

    No Time Machine backup - Time Machine backup not found.

Minor Issues:
    These issues do not need immediate attention but they may indicate future problems or opportunities for improvement. 

    Apps with heavy CPU usage - There have been numerous cases of apps with heavy CPU usage.
    Unsigned files - There are unsigned software files installed. They appear to be legitimate but should be reviewed.
    Heavy I/O usage - Your system is under heavy I/O use. This will reduce your performance.
    32-bit Apps - This machine has 32-bits apps will not work after macOS 10.14 “Mojave”.

Hardware Information:
    iMac (Retina 5K, 27-inch, 2019)
    iMac Model: iMac19,1
    1 3,7 GHz Intel Core i5 (i5-9600K) CPU: 6-core
    40 GB RAM - Upgradeable
        BANK 0/ChannelA-DIMM0 - 4 GB DDR4 2667 ok
        BANK 1/ChannelA-DIMM1 - 16 GB DDR4 2667 ok
        BANK 2/ChannelB-DIMM0 - 4 GB DDR4 2667 ok
        BANK 3/ChannelB-DIMM1 - 16 GB DDR4 2667 ok

Video Information:
    Radeon Pro 580X - VRAM: 8 GB
        iMac 5120 x 2880

Drives:
    disk0 - APPLE SSD SM0512L 500.28 GB (Solid State - TRIM: Yes)
    Internal PCI-Express 8.0 GT/s x4 NVM Express
        disk0s1 - EFI [EFI] 315 MB
        disk0s2 [APFS Container] 499.96 GB
            disk1 [APFS Virtual drive] 499.96 GB (Shared by 4 volumes)
                disk1s1 - Macintosh HD (APFS) (Shared - 171.48 GB used)
                disk1s2 - Preboot (APFS) [APFS Preboot] (Shared - 44 MB used)
                disk1s3 - Recovery (APFS) [Recovery] (Shared - 516 MB used)
                disk1s4 - VM (APFS) [APFS VM] (Shared - 2.15 GB used)

    disk2 - LaCie Rugged Mini USB3 4.00 TB
    External USB 5 Gbit/s USB
        disk2s1 - EFI (MS-DOS FAT32) [EFI] 210 MB
        disk2s2 - M*****A 4.00 TB (2.88 TB used)

Mounted Volumes:
    disk1s1 - Macintosh HD
        499.96 GB (Shared - 171.48 GB used - 325.62 GB free)
        APFS
        Mount point: /

    disk1s4 - VM [APFS VM]
        499.96 GB (Shared - 2.15 GB used - 325.62 GB free)
        APFS
        Mount point: /private/var/vm

    disk2s2 - M*****A
        4.00 TB (2.88 TB used - 1.12 TB free)
        Mount point: /Volumes/M*****A

Network:
    Interface en0: Ethernet
    Interface en1: Wi-Fi

    Interface en4: Bluetooth PAN
    Interface bridge0: Thunderbolt Bridge

System Software:
    macOS Mojave 10.14.5 (18F132) 
    Time since boot: Less than an hour

Notifications:
    (Deleted)
        one notification
    ~/Downloads/EtreCheckPro.app
        one notification

Security:
    Gatekeeper: App Store and identified developers
    System Integrity Protection: Enabled

Unsigned Files:
    Launchd: /Library/LaunchDaemons/com.edb.launchd.postgresql-9.3.plist
        Executable: /Library/PostgreSQL/9.3/bin/postmaster -D/Library/PostgreSQL/9.3/data
        Details: Exact match found in the whitelist - probably OK

32-bit Applications:
    2 32-bit apps

Kernel Extensions:
    /Library/Application Support/Logitech.localized/Logitech Options.localized
        [Not Loaded] LogiMgrDriver.kext (Logitech Inc., 7.12.1 - SDK 10.12)

    /Library/Extensions
        [Not Loaded] LogitechHIDDevices.kext (Logitech Inc., 3.9.8 - SDK 10.10)
        [Not Loaded] LogitechUnifying.kext (Logitech Inc., 1.3.8 - SDK 10.10)
        [Not Loaded] Dropbox.kext (Dropbox, Inc., 1.10.2 - SDK 10.14)

System Launch Agents:
    [Not Loaded] 17 Apple tasks
    [Loaded] 178 Apple tasks
    [Running] 106 Apple tasks

System Launch Daemons:
    [Not Loaded] 38 Apple tasks
    [Loaded] 193 Apple tasks
    [Running] 104 Apple tasks

Launch Agents:
    [Running] com.Logitech.Control Center.Daemon.plist (Logitech Inc. - installed 2019-03-25)
    [Running] com.logitech.manager.daemon.plist (Logitech Inc. - installed 2019-07-03)

Launch Daemons:
    [Running] com.edb.launchd.postgresql-9.3.plist (? 56bb852 - installed 2019-07-11)
    [Loaded] com.starstechnologies.updater.plist (Rational Intellectual Holdings Limited - installed 2019-07-11)

User Launch Agents:
    [Loaded] com.dropbox.DropboxMacUpdate.agent.plist (Dropbox, Inc. - installed 2019-07-11)

User Login Items:
    Skype.app (Skype Communications S.a.r.l - installed 2019-07-24)
        (Application - /Applications/Skype.app)

Audio Plug-ins:
    AppleTimeSyncAudioClock: 1.0 (Apple - installed 2019-05-04)
    BluetoothAudioPlugIn: 6.0.12 (Apple - installed 2019-05-04)
    AirPlay: 2.0 (Apple - installed 2019-05-04)
    AppleAVBAudio: 740.1 (Apple - installed 2019-05-04)
    BridgeAudioSP: 5.46 (Apple - installed 2019-05-04)
    iSightAudio: 7.7.3 (Apple - installed 2019-05-04)

3rd Party Preference Panes:
    Logitech Control Center (installed 2019-07-18)
    Logi Options Launcher (installed 2019-07-18)
    Mouse Acceleration (installed 2016-09-09)

Time Machine:
    Time Machine Not Configured!

Performance:
    System Load: 1.22 (1 min ago) 0.93 (5 min ago) 0.63 (15 min ago)
    Nominal I/O speed: 11.76 MB/s
    File system: 12.28 seconds
    Write speed: 718 MB/s
    Read speed: 836 MB/s

CPU Usage Snapshot:
    Type Overall
    System 2 %
    User 6 %
    Idle 91 %

Top Processes Snapshot by CPU:
    Process (count) CPU (Source - Location)
    EtreCheckPro 16.06 % (Etresoft, Inc.)
    WindowServer 9.66 % (Apple)
    TextEdit 6.44 % (Apple)
    kernel_task 1.77 % (Apple)
    hidd 0.56 % (Apple)

Top Processes Snapshot by Memory:
    Process (count) RAM usage (Source - Location)
    EtreCheckPro 627 MB (Etresoft, Inc.)
    mdworker_shared (13) 376 MB (Apple)
    Skype Helper (2) 337 MB (Skype Communications S.a.r.l)
    mds_stores 237 MB (Apple)
    Dock 110 MB (Apple)

Top Processes Snapshot by Network Use:
    Process Input / Output (Source - Location)
    Spotlight 108 KB / 6 KB (Apple)
    mDNSResponder 54 KB / 33 KB (Apple)
    Skype 27 KB / 58 KB (Skype Communications S.a.r.l)
    apsd 5 KB / 4 KB (Apple)
    netbiosd 618 B / 354 B (Apple)

Top Processes Snapshot by Energy Use:
    Process (count) Energy (0-100) (Source - Location)
    WindowServer 1 (Apple)
    Skype Helper (2) 0 (Skype Communications S.a.r.l)
    bluetoothd 0 (Apple)
    sharingd 0 (Apple)
    fseventsd 0 (Apple)

Virtual Memory Information:
    Physical RAM: 40 GB

    Free RAM: 31.67 GB
    Used RAM: 5.47 GB
    Cached files: 2.85 GB

    Available RAM: 34.53 GB
    Swap Used: 0 B

Software Installs (past 30 days):
    Install Date Name (Version)
    2019-07-11 XProtectPlistConfigData (2103)
    2019-07-11 Keynote (9.0)
    2019-07-11 Pages (8.0)
    2019-07-11 Numbers (6.0)
    2019-07-11 Disk Speed Test (3.2)
    2019-07-11 Vimeo (1.4.1)
    2019-07-13 BankID (7.7.1)
    2019-07-15 Master of Typing: Tutor (1.4.0)
    2019-07-18 Logitech Control Center (3.8.0)
    2019-07-18 Logitech Options (7.14)
    2019-07-18 Adblock Plus (2.0.6)
    2019-07-19 MRTConfigData (1.47)
    2019-07-23 Gatekeeper Configuration Data (173)

Diagnostics Information (past 7 days):
    2019-07-26 02:12:12 Final Cut Pro.app - High CPU Use (4 times)
        Executable: /Applications/Final Cut Pro.app

    2019-07-24 21:43:08 signpost_reporter - High CPU Use (6 times)
        Executable: /usr/libexec/signpost_reporter

    2019-07-22 20:02:00 com.apple.WebKit.WebContent - High CPU Use (2 times)
        Executable: /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.WebContent.xpc/Contents/MacOS/com.apple.WebKit.WebContent

End of report
  • idk whether it's any hint of a cause, but I notice you have both Logitech Control Centre & Logitech Options - do you actually have 2 Logitech devices running on different dongles? – Tetsujin Jul 26 at 17:31
  • No I have only one Logitech mouse and the dongle is not even connected now. I will remove those (or atleast one). However I think this issue was present even before Logitech installs. – Emil Jul 26 at 17:51
  • Apple provides free support. Give apple a call. Run hardware tests. Boot up in safe mode. Try a safe boot. Shutdown your machine. Hold down the shift key. Poweron. The boot up will take longer than normal because the filesystem on the startup drive is being checked and repaired as needed. All about safe mode including what features and apps safe boot leaves out. Safe boot uses a software driver instead of using your machines video hardware. support.apple.com/kb/ht1455 Your machine seems to be fairly can of addon software. – historystamp Jul 26 at 20:05
  • Hard freezing like this is almost always hardware related. Call Apple and start the diagnostic process with them. It looks like the RAM is replaceable so they may send you new RAM if that is the issue and you won't have to send it off. – Thomas Nelson Jul 27 at 5:14
  • Thank you! So it turns out it was the external hard drive. For some reason the new iMac starts to stall when trying to access the drive. Its a new LaCie 4TB rugged drive. I've ran several tests of the disk and haven't seen anything faulty but I believe it was a mistake to format it in ExFat.. I think it could have something to do with this. Because since I removed the drive I haven't had a single issue for 5 days while I use to have a problem once a day with it connected (running the same apps). – Emil Jul 31 at 11:59

You must log in to answer this question.

Browse other questions tagged .