0

When I add a new contact on my iPhone then after a few seconds I see it in my Google contacts. When I remove it from Google contacts, then within few seconds it's removed from my phone. So far so good.

However, I have a few contacts that I must have added on my phone in some strange way (maybe through another app like WhatsApp) that do not get synced. They are on my phone, but I do not find them in my Google contacts.

Does anyone experience similar? How can I fix this issue? Is there a way to force "all contacts sync" from my phone to Google?

device: iPhone X

iOS version: 12.3.1

Default account : Gmail with mail, contacts and calendar sync ON, no other account with contacts enabled; sync method : automatic fetch

  • Hey, welcome to Apple.SE! Please see if there is another account with contacts enabled in Accounts and Passwords in Settings. Also, if icloud is enabled and you might have a Mac, open the contacts app and you should see contacts separated by account being used. – ankii Jul 26 at 10:29
  • 1
    Hi @ankiiiiiii, thanks for suggestion. No there is no other account with contacts enabled. Also when I go to Settings>Contacts>Default account, there are only two options available: "Gmail" and "On my phone". Gmail is selected. – Michal B. Jul 26 at 10:46
1

Based on your description and follow-up comment it sounds like those few contacts got added to the On my phone group. You can check this by tapping the Groups button within Contacts (first screenshot below for reference) and then unchecking Gmail, which should leave just On my phone selected. If that shows the troublesome contacts, you have your answer.

Unfortunately there's no easy way to move contacts between accounts from Contacts. You have two options:

  1. Copy each one manually.
  2. You could tap Share Contact, Save to Files, delete the person from Contacts, then open in Files, open the Share Sheet, and tap Copy to Contacts. That should import it to your default account of Gmail. Second and third screenshots below for reference.

Showing *Groups* in *Contacts*.

Opening *Share Sheet* in *Files*. *Copy to Contacts* in *Share Sheet*.

  • You are right. But if I only display iPhone contacts I see like 50 of them. Is there a way to export them all at once? Is it possible to remove iPhone contacts group, so no contact is added there in the future? – Michal B. Jul 27 at 8:11
  • PS. I tried doing it like you said, but when I open the contact file in my files I can only view it. There is no option to copy it to contacts :/ – Michal B. Jul 27 at 8:19
  • I will accept your answer. Despite the fact it did not help me to move the contacts to gmail, it at least pointed me into the right direction. I would have never thought that moving contacts from one group to another could be so troublesome. I ended up exporting contacts to vcf and then importing vcf to my Google contacts using the desktop browser. – Michal B. Jul 27 at 8:59
  • Sorry about that. Do you have the Contacts app installed (rather than just using the Contacts tab in Phone)? Also, did you open the Share Sheet and scroll all the way to the right in the upper row? I will update my answer with additional screenshots to hopefully help others in the future since you figured out another solution. – Jawann Jul 27 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .