1

I'm often logged into a non-public Network, where I was given a user name and password for the captive portal to gain internet access.

In Safari on my MacBook, I made a bookmark for the portal page and stored the password. Now when I connect to the network, I can open the bookmark, click on the key symbol to fill my credentials and log in.

But since a few weeks (or months? I don't remember if it is connected to some update I made) about a second after filling the saved password, Safari suggests to use some cyptic password like it does when you register for some service. It's a nice feature when you are asked to invent a new password, but completely weird when logging in with a stored password (which I can't even change!).

Now I always need to click, that I don't want that suggested password and select the stored password a second time. How can I stop this annoying "feature"?

  • Try typing a different password in the form - even if you know it's going to be rejected. When Safari asks, tell it to remember. Repeat with correct password. My guess is keychain doesn't think it's an exact match, this should just jog its memory. – Tetsujin Jul 26 at 8:05
  • I did also try this, but to no avail. Same behaviour as before, unfortunally. – Philippos Aug 8 at 12:18
1

https://support.apple.com/guide/safari/passwords-sfri40599/mac

  • Open safari preferences and remove any saved passwords for the captive address (or all saved passwords)
  • turn off password saving in Safari entirely
  • turn off auto join for that network if you wish that as well
  • I did try this, did all the steps and turned password saving on again, logged in, stored the password and it's the same problem as before: I get suggested a strong password each time. But thank you for the suggestion anyhow. – Philippos Aug 4 at 19:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .