6

Yesterday I got a call from my wife and the iPhone said "Maybe Mrs. SSteve". The phone number was the international version of a U.S. phone number and her custom ringtone didn't play:

Incoming call

Voicemail is also showing international versions of U.S. phone numbers and also shows "Maybe" (normally it just shows the name and no phone number at all):

Voicemail

Contacts isn't formatting phone numbers at all:

Contacts

Contacts on my iPad still formats numbers the way I expect:

Contacts on iPad

I'm running iOS 12.3.1 on an iPhone 6. I remember seeing recently that there was a carrier update. I must have installed it because Settings -> General -> About doesn't show an available carrier update.

I tried iPhone Contact List Default Country Wrong but dialing *228 says the number isn't allowed.

I tried setting my Region in Settings -> General -> Language & Region away from United States and back but that didn't work. Where else does iOS get the region for phone numbers?

3

When I was writing this question and was in Language & Region, I tried setting the iPhone Language even though I didn't expect it to do anything. It was already set to English but I went ahead and selected "English (US)". It went to a black screen that said "Setting Language" (or something similar) for a while and when it was done all the phone numbers are displaying correctly. So I guess it's possible the language wasn't set to "English (US)" but I can't imagine why. Anyway, since I already went through the effort of editing the screenshots and writing the question I figured I'd leave this here in case it's helpful to someone.

  • It's perfectly OK to answer one's own question, it can help others who face the same issue. Consider selecting the check mark by your answer to indicate that the answer provided is correct. – David Jul 22 at 0:59
  • @David Thanks. I will, but I have to wait two days. – SSteve Jul 22 at 6:14
  • I had a similar problem after traveling abroad with an eSIM/physical-SIM combo. All my local (to home) numbers were saying they were coming from as different country (and I don't live on a board or anything). After calling Apple support, we eventually had to "Reset Network Settings," which solved the problem for me. It took a minute or two and required a reboot, but I didn't lose anything from the phone except maybe wifi passwords. – Christopher Schultz Jul 22 at 12:43
  • Like Christopher, I got this problem from my esim/phys sim adventure overseas, first time I have used it. I tried the language -- no fix for me. Tried reset network settings -- also no fix for me. I am in USA and if I dial 510-555-1212, an Oakland, CA # -- it still thinks that is Australia. I'll try to post when I fix! – JDH Aug 27 at 22:23
  • OK, for me it came down to turning off "dial assist" (search your settings for the dial assist menu). To get that menu available, i had to have a second SIM in the hard sim slot in addition to my primary AT&T line (now on the e-sim), so I popped one in temporarily. – JDH Aug 27 at 22:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .