0

I disabled the service as per the instructions on this page: How to disable Apple Push Notification Service (apsd) on OS X 10.8?

Yet this service is still running at startup!

How do I disable it once and for all?

Edit: I'm using Mojave

  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. All the best with your question. – Monomeeth Jul 21 at 23:50
  • Case39, are you saying that the correct answer on the page you linked doesn’t work? – existing person Jul 22 at 2:22
  • Like I said, it didn't work for me. – Case39 Jul 22 at 2:46
1

Found this googling around:

If you don't use FaceTime, put this in a Terminal window to get rid of apsd permanently: "sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.apsd.plist"

This will unload apsd from launchctl (the process that launches it at startup), but you'll still need to kill now.

  • This is what I did after disabling System Integrity Protection, but apsd is still trying to connect to Apple servers about every 4 minutes. – Case39 Jul 22 at 2:52
0

I finally just changed the permission of /System/Library/PrivateFrameworks/ApplePushService.framework/apsd after disabling System Integrity Protection and reenabling it when done.

I'm still wondering why I couldn't disable apsd the normal way though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .