0

I cannot get my MacPro 3.1 early 2008 to recognise a bootable USB stick. I'm trying to upgrade from 10.11 El Capitan, to a newer version using the unoffical patcher tools. I've tried both Mojave, and High Sierra and niether will work.

The USB stick is formatted Mac OS Extended (Journaled), with a GUID partition map.

I have verified that the stick is working using my Macbook Air. The Air recognised and booted fine from the USB stick when trying both macOS versions, so the stick is fine.

I've tried holding the Comand + Option + R + P at boot multiple times, which hasn't worked.

I've also tried multiple USB ports, including one that a timemachine external drive was connected to (which does interesting show on the boot options screen) and still nothing.

Why is this not working? Does anything need to be enabled?

  • I've never got any 3,1 to boot from USB either. Some people claim it's possible, but other than an AHT key, never managed it in 10 years. Being a Pro, though, it's simple enough to just put another drive in with the required boot volume. – Tetsujin Jul 21 at 16:10
  • @Tetsujin feel free to edit my answer, I’m with you in that I don’t think usb boot was officially supported so maybe some EEE codes worked, others not. – bmike Jul 21 at 16:26
  • @bmike - tbh, other than 'make a boot drive in another machine & sneaker-net it over', I've actually never really gone much further. I've always just considered the fact you can get 6 drives in it to be free space to fiddle, without trying to bypass what seems to be a hardware limitation :) – Tetsujin Jul 21 at 16:30
  • 1
    Looking at the DosDude stuff [which I've never actually used] you can do this without booting from an external drive - just run the patched updater as normal. – Tetsujin Jul 21 at 16:35
1

When that model was released, the mainstream boot support was FireWire and APT and not GUID format. If you can’t try that, you’ll want to get a USB to sata controller ($5 to $10) and write the data to a sata drive and connect that bus.

You should be able to USB boot on Intel Macs, though and the only articles I can find show 10.4.5 adding boot support, so I think you might also just have a hardware issue.

  • MacPro model is 3.1, ie. early 2008. – hojkoff Jul 21 at 16:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .