1

I turned on font smoothing in VSCode using the following commands:

defaults write com.microsoft.VSCode CGFontRenderingFontSmoothingDisabled 0
defaults write com.microsoft.VSCode.helper CGFontRenderingFontSmoothingDisabled 0
defaults write com.microsoft.VSCode.helper.EH CGFontRenderingFontSmoothingDisabled 0
defaults write com.microsoft.VSCode.helper.NP CGFontRenderingFontSmoothingDisabled 0

This was taken from Reddit.

But how do I revert it back? I tried doing defaults com.microsoft.VSCode delete -g CGFontRenderingFontSmoothingDisabled but didn't work.

1

For each defaults write x y z run defaults delete x y,
where x is the domain, y is the key and z is the value.

For example, to delete the first key that was set, run

defaults delete com.microsoft.VSCode CGFontRenderingFontSmoothingDisabled
  • Omit the value (e.g. 0) when deleting a key since the key is deleted regardless of value.
  • -g is a reference to the global domain; if you didn't write the key to the global domain then don't include -g when deleting.
  • The delete or write verb needs to go before other options like the domain, not after.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .