2

I have recently got a mid 2012 Macbook Air which I installed Lion on. I am trying to update it to Mojave, but even though it is compatible, when downloading it in the App Store I get this error message:

error message

How can I upgrade my Mac to Mojave? Do I need to upgrade to OS X 10.8 first?

2

Refer to this macOS upgrade instructions webpage, (currently it refers to macOS Mojave):

Upgrading from OS X Snow Leopard or Lion

If you’re running Snow Leopard (10.6.8) or Lion (10.7) and your Mac supports macOS Mojave, you will need to upgrade to El Capitan (10.11) first. Click here for instructions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .