0

[I have two not-really-related questions about timed, so I'm asking them separately. The other one is "timed not always working?".]

I just upgraded to High Sierra (yeah, I'm a bit behind the times), and I just discovered this new system time daemon, timed, which is evidently new with 10.13. Unlike my previous Macs, this machine does not seem to be acting as an NTP server -- that is, it is not accepting incoming NTP connections on port 123, even from the local host.

I can see that it uses the configuration file /etc/ntp.conf, and presumably if I put the right lines in there it might do what I want, but I have no way of knowing whether it accepts all the same directives there as ntpd does, so I'm afraid it may be a bit of a crapshoot. Anybody know of an "official" or sanctioned way? Right now ntp.conf consists of the single line

server time.apple.com.

(At the moment I only care about accepting NTP connections from this machine, but eventually I may also want to accept them from the local network.)

P.S. I was thinking there was a chance this might have something to do with firewall settings ("do/don't accept incoming connections"), although now I'm doubting that. At @nohillside's suggestion, I tried fetching time on it (hitting it on NTP port 123) from an outside machine, and that failed, too. (I've confirmed that I can fetch time by making NTP connections from this machine to other NTP servers, such as time.apple.com.)

  • Please add the content of your ntp.conf. Also, to check the firewall settings, can you verify that you can reach the time server using ncat or telnet from another system within your network? – nohillside Jul 19 at 17:08
  • @nohillside Question updated -- do those address your suggestions? – Steve Summit Jul 19 at 17:33
  • My bad, I thought you've already tried to change ntp.conf. Without any changes there, hitting port 123 won't work. – nohillside Jul 19 at 17:35

You must log in to answer this question.

Browse other questions tagged .