0

I have a late 2013 MacBook Pro running iTerm2. I don't have tmux installed on it, but I use tmux on the remote Linux host I frequently connect to via ssh. When tmux is displaying a vertical split and I use the trackpad to select text, the selection is automatically limited to just one pane. That's exactly how I want it.

I have recently begun using a 2018 MacBook Pro. Using the same iTerm2 version (3.2.9), and the same remote tmux session, text selection spans the entire window width instead of staying in a single pane.

What setting controls that behavior?

I'm aware I can hold Command+Option to select a block of text, but that's not what I'm after. I'm looking to select, for example, a sentence that starts mid-paragraph and spans multiple lines. Block selection doesn't allow that.

1

tmux panes are simply logical windows emulated within a single text field. This means that the OSX system-level text handling does not recognize the tmux panes as separate fields. To get the behavior you desire you'll need to override or simply not use the default OS behavior.

Instead, you'll need to learn to use tmux's own internal selection/copy functionality (Copy Mode). This respects pane boundaries and enables selection/move/copy using non-system-hotkey presses.

See this cheat sheet for info on how to use it: https://tmuxcheatsheet.com/

EDIT: Ah, then you need to enable mouse mode. See https://stackoverflow.com/questions/11832199/tmux-set-g-mouse-mode-on-doesnt-work#33336609 and similar answers

  • As I explained, it's definitely possible because I already have the desired behavior on one MacBook. I'm asking how to get that same behavior on another one. Maybe iTerm2 on my "working" system isn't using the "default OS behavior," but the question remains as to how to make my other system do the same thing. – Rob Kennedy Jul 19 at 18:23
  • Ah, then you need to enable mouse mode. See stackoverflow.com/questions/11832199/… and similar answers – Barrett Jul 19 at 19:52
  • It's not a tmux setting. Recall that it's the very same tmux session I'm accessing from both Macs. The difference is on the Mac end, not the Linux/tmux end. – Rob Kennedy Jul 19 at 20:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .