3

I have a number of iMacs running Sierra/High Sierra/Mojave, which I'm adding to a client's Windows Active Directory. Everything is going well, but I've hit a tiny snag that I can't work out.

I have one iMac, running Mojave, that I have previously logged into with my AD account with no issues. It is possible that I left the screen locked and myself logged in, and then subsequently have changed my account password. Now I am unable to log back into the iMac - just get the shakey password. The machine has been rebooted a number of times since.

I've tried removing the user profile for my account from the Users folder - no difference.

I've tried unbinding the machine from the AD and rejoining, but no dice. I can log in with other AD accounts, so it's clearly not an issue with the binding.

I can log into the machine over SSH with my domain account creds, and authenticate administrator actions if logged in as a non-admin user with them too, so clearly the machine knows my creds are good and that I'm an administrator.

It's like there's something cached that needs cleared out, but I'm lost as to what.

I'd greatly appreciate any advice - I don't want to have to deal with Users having the same issue in the future without a way forward.

1

Interestingly, I found a solution for my issue after some testing. In the hope that it helps someone else, this is what I found.

My initial, and many subsequent logins on the device were just Username & Password, and this just stopped working. When I tried domain\username and password it sailed through, asked me to update my keychain, and I was logged in.

That's quite an unusual change of behaviour, as if the device had forgotten that my account was a network account, and was trying to authenticate it locally. There's only one local account configured on the device and the name of it is nowhere close to the name of my network account.

I think I'm going to recommend all users to login using their domain\username as their login name, in order to avoid any support calls for this issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .