1

So I’m trying to delete a specific user account while avoiding the traditional SysPrefs method. I do have FileVault enabled and am running 10.14. This is what I’ve tried in Single User mode:

/sbin/fsck -fy
/sbin/mount -uw /
sudo dscl . delete /Users/username

This gives me the errors:

Could not read path = /System/Library/LaunchDaemons/com.apple.DirectoryServicesLocal.plist, error = 2: No such file or directory
No task-access server configured! The system will not get very far.

When I try the dscl command in Recovery Mode I get the DS error -14009. Any clue as to why this is?

2
  • Does it help if you run launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist after mounting? – nohillside Jul 19 '19 at 8:17
  • @nohillside Perfect that worked! Thanks! – Jack Brandon Jul 19 '19 at 8:32
1

Solved! Since com.apple.DirectoryServicesLocal.plist was giving me issues I ran

launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist

Before executing the dscl delete command which was successful.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .