After working fine for months, my wifi Time Capsule backups fail, returning a "back-up disk not available" message. Time Capsule light is green, Airport Utility reveals no problems. What do I do? Thanks.

4 Answers 4


I see this every few months and all other features of the device seem to work fine when it happens. The short answer is a restart has always fixed it for me, either from the Airport Utility or if you must by cycling the power.


Are you connected to the 5ghz wifi or the normal wifi ?

I had the exact same problem you describe, Airport Utility showed nothing wrong, green lights across the board, but when trying to do a Time Machine backup, it wouldn't be able to find the disk.

Additionally, I was also unable to access the Time Capsule's disk through Finder. It shows up alright, but I could not connect.

Manually switching wifi network to the non-5ghz one solved both the backup and Finder problems.


Try changing the TC disk name. Worked for me.


From Tesserax's answer from June 2018 on the Apple Communities:

Use a 16-character or less base station name for the TC. Also do not include special characters or spaces in the name.

This solved the "Backup Disk Not Available" for me in 2020 on macOS Catalina with an Airport Time Capsule version 7.9.1.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .