6

I have an up-to-date Macbook Air on which the sound no longer works.

I had installed Soundflowerbed on it, and for a long time everything was working fine until a couple of weeks ago when it started to not work after a while.

Then it stopped completely.

I uninstalled Soundflowerbed, reset using:

  • command + alt + P + R, and
  • shift + ctrl + alt

but, still the sound does not work.

The Sound devices view look like this:

and, the input devices:


What can I do to get the sound back? I did the hardware tests (pressing D while booting), and there are no issues.

Also, I am pretty sure it is not a hardware issue.

Is there a way to reinstall the sound drivers or something like that?


I did a fresh install, reinstalling the whole system and the sound worked for one day, and now I have the same issue...

  • 1
    First, you said you did the Shift, CTRL ALT combo, did you do it then pressed and released the power button like prescribed, to reset the SMC? Second, try booting it from another system, like from a bootable USB or from another mac put in target mode, and check if you get sound. This will indicate whether it is a software or hardware issue – Lars A. Gundersen Jul 17 at 18:30
  • Every client ever: "everything was working fine until it started to not work". Take my upvote :) – user3247189 Jul 28 at 7:58
  • Its not a good sign that the reinstall did not resolve the issue... – Thomas Nelson Jul 30 at 0:03
  • @ThomasNelson GhitaB's answer is the right one... The problem is solved... but I don't know why this happened... – Ionică Bizău Jul 31 at 11:32
3
+50
  1. Shut down the Macbook
  2. Press shift + ctrl + alt and press the power button. Notice the change in power led color if the Macbook is connected to power. Note this won't start the Macbook.
  3. Now, press command + alt + P + R, and press the power button. You will see the screen flashing a couple of times. This won't power on the Macbook either.
  4. Now, start the Macbook normally.
  5. Enjoy!
  • That worked!!! Thank you! – Ionică Bizău Jul 31 at 11:32
  • @IonicăBizău I'm glad this worked for you, that's great news! :) For the benefit of others, any idea why this worked for you this time and not the original time you did this? – Monomeeth Jul 31 at 11:49
  • @Monomeeth Could it be that the order of the actions matters...? I don't have a clear image of these reset functions... – Ionică Bizău Jul 31 at 12:01
  • 1
    @IonicăBizău Yes, I was wondering the same thing. Often, if needing to reset both the NVRAM and SMC, resetting the NVRAM first is the way to go. I don't recall a situation where the opposite is preferred, but will take note of this for the next time I come across the same symptoms you had. Would be interesting to test for! Regardless, glad it's sorted and hopefully it stays that way! :) – Monomeeth Jul 31 at 12:22
  • @Monomeeth I have again the same problem... Usually after letting the MBA to sleep, this problem appears again, and after restarting + resetting the problem is solved... Do you have any idea why this is happening? – Ionică Bizău Aug 2 at 12:50
3

The next thing I would do is try booting into Safe Mode.

Boot into Safe Mode

Follow these steps to boot your MBA into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. does sound work, do you have sound devices listed in your Sound preference pane, etc)
  6. Exit Safe Mode by restarting your Mac as normal
  7. Test again when booted normally

Let me know how these steps went and we'll go from there.

Check what 'coreaudiod' is doing

Since booting into Safe Mode makes no difference, the next time you encounter this problem you can use Activity Monitor to check what coreaudiod is doing.

To do this:

  1. Open Activity Monitor (by default this is located in Macintosh HD > Applications > Utilities)
  2. In the Search field at top right of the window, enter the following: coreaudiod
  3. Now click the CPU and Memory tabs in turn to see how much of the CPU and how much memory is being used by coreaudiod
  4. Make a note of the CPU percentage and amount of memory (for future reference)
  5. Now select the coreaudiod process by clicking on it
  6. Quit the process by pressing the optioncommandQ keys - or you can click on the button at top left of the window (as per the image below):

enter image description here

  1. Now check to see if your Input & Output devices are available again (without having to restart your Mac)

Assuming this solves your problem, at least you now have a much easier solution the next time it happens!

Note: Re step 4 above, before leaving your Mac and letting it go to sleep again, go through the process to check what coreaudiod is doing and make a note of this. Then, after waking from sleep, if the problem returns check again to see what coreaudiod is doing.

  • There is no sound in Safe Mode either... – Ionică Bizău Jul 31 at 11:21
  • While coreaudiod was not found in Activity Monitor, I found the process via ps aux | grep coreaudiod and killed it (sudo kill <pid>), but there is still no change in the sound output/input items... – Ionică Bizău Aug 4 at 7:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .